CVE-2004-2315
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:47
NMCO    

[原文]Mbedthis AppWeb HTTP server before 1.0.2 allows remote attackers to cause a denial of service (crash) via an empty OPTIONS request.


[CNNVD]Mbedthis Software AppWeb HTTP Server设备名访问拒绝服务漏洞(CNNVD-200412-237)

        
        Mbedthis Software AppWeb是一款Windows平台下的小型HTTP服务程序。
        Mbedthis Software AppWeb在处理畸形的用户请求时存在漏洞,远程攻击者可以利用此漏洞导致服务器程序无法正常提供服务。
        如果攻击者通过HTTP请求访问Windows设备名访问,可以导致服务器程序崩溃。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mbedthis_software:mbedthis_appweb_http_server:1.0.1
cpe:/a:mbedthis_software:mbedthis_appweb_http_server:1.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2315
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2315
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-237
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/14926
(PATCH)  XF  mbedthis-multiple-dos(14926)
http://www.securityfocus.com/bid/9494
(PATCH)  BID  9494
http://secunia.com/advisories/10710/
(PATCH)  SECUNIA  10710

- 漏洞信息

Mbedthis Software AppWeb HTTP Server设备名访问拒绝服务漏洞
中危 其他
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        Mbedthis Software AppWeb是一款Windows平台下的小型HTTP服务程序。
        Mbedthis Software AppWeb在处理畸形的用户请求时存在漏洞,远程攻击者可以利用此漏洞导致服务器程序无法正常提供服务。
        如果攻击者通过HTTP请求访问Windows设备名访问,可以导致服务器程序崩溃。
        

- 公告与补丁

        厂商补丁:
        Mbedthis Software
        -----------------
        目前厂商已经在1.0.2及以上版本的软件中修复了这个安全问题,请到厂商的主页下载:
        
        http://www.mbedthis.com/

- 漏洞信息

19468
Mbedthis AppWeb Empty OPTIONS Request Remote DoS
Remote / Network Access Denial of Service
Loss of Availability Upgrade
Exploit Unknown Vendor Verified

- 漏洞描述

Appweb for Windows contains a flaw in the handling of certain HTTP requests that may allow a remote denial of service. The issue is triggered when an attacker sends an empty OPTIONS request, which may allow a remote attacker to cause the service to crash.

- 时间线

2004-01-26 Unknow
Unknow 2004-02-02

- 解决方案

It has been reported that this issue has been fixed. Upgrade to version 1.0.1, or higher, to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站