CVE-2004-2292
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:43
NMCO    

[原文]Buffer overflow in Alt-N MDaemon 7.0.1 allows remote attackers to cause a denial of service (application crash) via a long STATUS command to the IMAP server.


[CNNVD]Alt-N MDaemon远程STATUS命令远程缓冲区溢出漏洞(CNNVD-200412-1016)

        
        Alt-N MDaemon是一款基于Windows的邮件服务程序。
        Alt-N MDaemon的IMAP组件处理STATUS命令时对参数缺少充分边界检查,远程攻击者可以利用此漏洞对服务程序进行缓冲区溢出攻击,可能以进程权限在系统上执行任意指令。
        攻击者以合法帐号登录到服务后后,发送包含超长参数的STATUS命令给IMAP组件处理,可发生基于堆栈的缓冲区溢出,精心构建提交数据可能以进程权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:alt-n:mdaemon:3.5.4
cpe:/a:alt-n:mdaemon:3.5.1
cpe:/a:alt-n:mdaemon:6.7.5
cpe:/a:alt-n:mdaemon:3.1.1
cpe:/a:alt-n:mdaemon:3.5.6
cpe:/a:alt-n:mdaemon:6.8.2
cpe:/a:alt-n:mdaemon:6.0.6
cpe:/a:alt-n:mdaemon:6.7.9
cpe:/a:alt-n:mdaemon:6.0.5
cpe:/a:alt-n:mdaemon:3.1.2
cpe:/a:alt-n:mdaemon:2.8.5.0
cpe:/a:alt-n:mdaemon:6.0.7
cpe:/a:alt-n:mdaemon:3.5.0
cpe:/a:alt-n:mdaemon:3.0.3
cpe:/a:alt-n:mdaemon:6.5.0
cpe:/a:alt-n:mdaemon:6.8.0
cpe:/a:alt-n:mdaemon:3.0.4
cpe:/a:alt-n:mdaemon:6.0
cpe:/a:alt-n:mdaemon:5.0.7
cpe:/a:alt-n:mdaemon:6.5.2
cpe:/a:alt-n:mdaemon:3.1_beta
cpe:/a:alt-n:mdaemon:2.71_sp1
cpe:/a:alt-n:mdaemon:2.8
cpe:/a:alt-n:mdaemon:6.8.4
cpe:/a:alt-n:mdaemon:6.8.5
cpe:/a:alt-n:mdaemon:6.8.3
cpe:/a:alt-n:mdaemon:6.8.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2292
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2292
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-1016
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/16118
(PATCH)  XF  mdaemon-imap-status-bo(16118)
http://www.securityfocus.com/bid/10366
(UNKNOWN)  BID  10366
http://archives.neohapsis.com/archives/fulldisclosure/2004-05/0527.html
(UNKNOWN)  FULLDISC  20040512 Mdaemon 7.0.1 IMAP overflow.

- 漏洞信息

Alt-N MDaemon远程STATUS命令远程缓冲区溢出漏洞
中危 边界条件错误
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        Alt-N MDaemon是一款基于Windows的邮件服务程序。
        Alt-N MDaemon的IMAP组件处理STATUS命令时对参数缺少充分边界检查,远程攻击者可以利用此漏洞对服务程序进行缓冲区溢出攻击,可能以进程权限在系统上执行任意指令。
        攻击者以合法帐号登录到服务后后,发送包含超长参数的STATUS命令给IMAP组件处理,可发生基于堆栈的缓冲区溢出,精心构建提交数据可能以进程权限在系统上执行任意指令。
        

- 公告与补丁

        厂商补丁:
        Alt-N
        -----
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://mdaemon.deerfield.com/

- 漏洞信息

19036
MDaemon IMAP Server STATUS Command Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Commercial

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-05-12 Unknow
2004-05-12 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站