CVE-2004-2267
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:39
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in Ansel 2.1 and earlier allows remote attackers to inject arbitrary HTML or web script via the album name.


[CNNVD]Ansel多个输入验证漏洞(CNNVD-200412-464)

        Ansel 2.1版本及之前版本存在跨站脚本(XSS)漏洞。远程攻击者可以借助专集名称注入任意HTML或web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2267
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2267
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-464
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/18374
(PATCH)  XF  ansel-albumname-xss(18374)
http://www.securityfocus.com/bid/11824
(PATCH)  BID  11824
http://www.osvdb.org/12237
(PATCH)  OSVDB  12237
http://securitytracker.com/id?1012434
(PATCH)  SECTRACK  1012434
http://secunia.com/secunia_research/2004-17/advisory/
(VENDOR_ADVISORY)  MISC  http://secunia.com/secunia_research/2004-17/advisory/
http://secunia.com/advisories/12856
(VENDOR_ADVISORY)  SECUNIA  12856

- 漏洞信息

Ansel多个输入验证漏洞
中危 跨站脚本
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Ansel 2.1版本及之前版本存在跨站脚本(XSS)漏洞。远程攻击者可以借助专集名称注入任意HTML或web脚本。

- 公告与补丁

        The vendor has released an update to address these issues:
        Ansel Ansel 1.0
        
        Ansel Ansel 1.1
        
        Ansel Ansel 1.2
        
        Ansel Ansel 1.3
        
        Ansel Ansel 1.4
        
        Ansel Ansel 2.0
        
        Ansel Ansel 2.1
        

- 漏洞信息

12237
Ansel album name Variable Arbitrary Script Injection
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public

- 漏洞描述

Ansel contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the album name variable upon submission to the gallery script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-12-06 2004-11-12
Unknow Unknow

- 解决方案

Upgrade to version 2.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站