CVE-2004-2266
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2017-07-10 21:31:45
NMCO    

[原文]SQL injection vulnerability in Ansel 2.1 and earlier allows remote attackers to modify SQL statements via the image parameter.


[CNNVD]Ansel多个输入验证漏洞(CNNVD-200412-230)

        Ansel 2.1版本及之前版本中存在SQL注入漏洞。远程攻击者可以借助image参数修改SQL语句。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:ansel:ansel:1.0
cpe:/a:ansel:ansel:1.2
cpe:/a:ansel:ansel:2.0
cpe:/a:ansel:ansel:1.1
cpe:/a:ansel:ansel:2.1
cpe:/a:ansel:ansel:1.4
cpe:/a:ansel:ansel:1.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2266
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2266
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-230
(官方数据源) CNNVD

- 其它链接及资源

http://securitytracker.com/id?1012434
(PATCH)  SECTRACK  1012434
http://www.securityfocus.com/bid/11824
(PATCH)  BID  11824
https://exchange.xforce.ibmcloud.com/vulnerabilities/18373
(UNKNOWN)  XF  ansel-image-sql-injection(18373)

- 漏洞信息

Ansel多个输入验证漏洞
高危 SQL注入
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Ansel 2.1版本及之前版本中存在SQL注入漏洞。远程攻击者可以借助image参数修改SQL语句。

- 公告与补丁

        The vendor has released an update to address these issues:
        Ansel Ansel 1.0
        
        Ansel Ansel 1.1
        
        Ansel Ansel 1.2
        
        Ansel Ansel 1.3
        
        Ansel Ansel 1.4
        
        Ansel Ansel 2.0
        
        Ansel Ansel 2.1
        

- 漏洞信息

12236
Ansel image Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Ansel contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the image parameter is not verified properly before being submitted in a SQL query and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-12-06 2004-11-12
2004-12-06 Unknow

- 解决方案

Upgrade to version 2.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站