CVE-2004-2261
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:38
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in e107 allows remote attackers to inject arbitrary script or HTML via the "login name/author" field in the (1) news submit or (2) article submit functions.


[CNNVD]e107网站系统多个脚本HTML注入漏洞(CNNVD-200412-430)

        e107中存在跨站脚本(XSS)漏洞。远程攻击者可以借助(1)新闻提交或(2)文章提交函数中的"login name/author"字段注入任意脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2261
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2261
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-430
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/10293
(PATCH)  BID  10293
http://www.osvdb.org/5982
(PATCH)  OSVDB  5982
http://secunia.com/advisories/11567
(VENDOR_ADVISORY)  SECUNIA  11567
http://xforce.iss.net/xforce/xfdb/16087
(UNKNOWN)  XF  e107-news-submit-xss(16087)
http://securitytracker.com/id?1010084
(UNKNOWN)  SECTRACK  1010084

- 漏洞信息

e107网站系统多个脚本HTML注入漏洞
中危 跨站脚本
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        e107中存在跨站脚本(XSS)漏洞。远程攻击者可以借助(1)新闻提交或(2)文章提交函数中的"login name/author"字段注入任意脚本或HTML。

- 公告与补丁

        This issue has been reported to be fixed by the vendor:
        e107.org e107 website system 0.545
        
        e107.org e107 website system 0.554
        
        e107.org e107 website system 0.555 Beta
        
        e107.org e107 website system 0.6 13
        
        e107.org e107 website system 0.6 12
        
        e107.org e107 website system 0.6 10
        
        e107.org e107 website system 0.6 11
        
        e107.org e107 website system 0.6 14
        
        e107.org e107 website system 0.603
        

- 漏洞信息

5982
e107 Login Name/Author XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

E107 version 0.614 contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate variables "login name/author" upon submission to the "news submit" and "article submit" scripts with guest user privilege. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-05-06 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.615 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站