CVE-2004-2259
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2010-08-21 00:24:02
NMCO    

[原文]vsftpd before 1.2.2, when under heavy load, allows attackers to cause a denial of service (crash) via a SIGCHLD signal during a malloc or free call, which is not re-entrant.


[CNNVD]Vsftpd Listener远程拒绝服务漏洞(CNNVD-200412-458)

        
        vsftpd是一款安全加强的FTP服务程序。
        vsftpd部分处理连接的代码存在问题,远程攻击者可以利用这个漏洞对FTP服务程序进行拒绝服务攻击。
        Vsftpd's listener进程在连接处理代码中不正确调用非重入函数,可导致进程变的不稳定,而导致拒绝服务攻击。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:beasts:vsftpd:1.2.0
cpe:/a:beasts:vsftpd:1.2.1

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:11049vsftpd before 1.2.2, when under heavy load, allows attackers to cause a denial of service (crash) via a SIGCHLD signal during a malloc or fr...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2259
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2259
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-458
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/16222
(PATCH)  XF  vsftpd-connection-dos(16222)
http://www.osvdb.org/6306
(PATCH)  OSVDB  6306
http://secunia.com/advisories/11736
(VENDOR_ADVISORY)  SECUNIA  11736
http://secunia.com/advisories/11680
(VENDOR_ADVISORY)  SECUNIA  11680
http://rhn.redhat.com/errata/RHBA-2004-164.html
(PATCH)  REDHAT  RHBA-2004-164
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=119136
(UNKNOWN)  CONFIRM  http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=119136
ftp://vsftpd.beasts.org/users/cevans/untar/vsftpd-1.2.2/Changelog
(UNKNOWN)  CONFIRM  ftp://vsftpd.beasts.org/users/cevans/untar/vsftpd-1.2.2/Changelog
http://www.securityfocus.com/bid/10394
(UNKNOWN)  BID  10394

- 漏洞信息

Vsftpd Listener远程拒绝服务漏洞
中危 竞争条件
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        vsftpd是一款安全加强的FTP服务程序。
        vsftpd部分处理连接的代码存在问题,远程攻击者可以利用这个漏洞对FTP服务程序进行拒绝服务攻击。
        Vsftpd's listener进程在连接处理代码中不正确调用非重入函数,可导致进程变的不稳定,而导致拒绝服务攻击。
        

- 公告与补丁

        厂商补丁:
        Vsftpd
        ------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Vsftpd Upgrade vsftpd-1.2.2.tar.gz
        ftp://vsftpd.beasts.org/users/cevans/vsftpd-1.2.2.tar.gz

- 漏洞信息

6306
vsftpd Connection Handling DoS
Remote / Network Access Denial of Service
Loss of Availability
Exploit Unknown

- 漏洞描述

vsftpd contains a flaw that may allow a remote denial of service. The issue is triggered due to an error within the connection handling, which could cause the builtin listener to hang or crash under heavy connect/disconnect loads, resulting in a loss of availability for the ftp server.

- 时间线

2004-03-25 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.2.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站