CVE-2004-2254
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:37
NMCOE    

[原文]SurgeLDAP 1.0g (Build 12), and possibly other versions before 1.0h, allows remote attackers to bypass authentication for the administration interface via a direct request to admin.cgi with a modified utoken parameter.


[CNNVD]SurgeLDAP Web管理验证绕过漏洞(CNNVD-200412-335)

        
        SurgeLDAP是一款高级易管理的高性能的LDAP v3服务器。
        SurgeLDAP Web管理应用程序验证实现存在问题,远程攻击者可以利用这个漏洞未授权访问管理程序,可修改LDAP数据库记录,破坏数据,使服务器崩溃等。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:netwin:surgeldap:1.0e
cpe:/a:netwin:surgeldap:1.0b
cpe:/a:netwin:surgeldap:1.0g
cpe:/a:netwin:surgeldap:1.0f
cpe:/a:netwin:surgeldap:1.0d
cpe:/a:netwin:surgeldap:1.0a

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2254
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2254
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-335
(官方数据源) CNNVD

- 其它链接及资源

http://www.osvdb.org/5890
(PATCH)  OSVDB  5890
http://securitytracker.com/alerts/2004/May/1010113.html
(PATCH)  SECTRACK  1010113
http://netwinsite.com/surgeldap/updates.htm
(PATCH)  CONFIRM  http://netwinsite.com/surgeldap/updates.htm
http://xforce.iss.net/xforce/xfdb/16076
(UNKNOWN)  XF  surgeldap-admin-auth-bypass(16076)
http://www.securityfocus.com/bid/10294
(UNKNOWN)  BID  10294
http://securitytracker.com/id?1010068
(UNKNOWN)  SECTRACK  1010068
http://secunia.com/advisories/11549
(VENDOR_ADVISORY)  SECUNIA  11549

- 漏洞信息

SurgeLDAP Web管理验证绕过漏洞
高危 访问验证错误
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        SurgeLDAP是一款高级易管理的高性能的LDAP v3服务器。
        SurgeLDAP Web管理应用程序验证实现存在问题,远程攻击者可以利用这个漏洞未授权访问管理程序,可修改LDAP数据库记录,破坏数据,使服务器崩溃等。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        NetWin
        ------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://netwinsite.com/surgeldap/

- 漏洞信息 (24094)

SurgeLDAP 1.0 Web Administration Authentication Bypass Vulnerability (EDBID:24094)
cgi webapps
2004-05-05 Verified
0 GSS IT
N/A [点击下载]
source: http://www.securityfocus.com/bid/10294/info

SurgeLDAP is an LDAP server implementation for Microsoft Windows and various Unix operating systems. It includes a built-in web server to permit remote user access via HTTP. 

It has been reported that the SurgeLDAP web administration application is prone to an authentication bypass vulnerability, possibly allowing remote attackers manager access.

Once administration access is granted, it may be possible for an attacker to modify records in the LDAP database, destroy data, crash the server, or possibly further attacks on other services utilizing SurgeLDAP for it's authentication data.

http://www.example.com/admin.cgi?cmd=show&page=main.tpl&utoken=manager		

- 漏洞信息

5890
SurgeLDAP admin.cgi utoken Variable Authentication Bypass
Remote / Network Access Authentication Management
Loss of Integrity
Exploit Public

- 漏洞描述

SurgeLDAP contains a flaw that may allow a malicious user to bypass user authentication and gain access to the administrative web interface. The issue is triggered when the HTTP module is loaded and admin.cgi is enabled. It is possible that the flaw may allow an attacker to gain administrative privileges resulting in a loss of integrity.

- 时间线

2004-05-06 2004-03-28
2004-05-06 Unknow

- 解决方案

Upgrade to version 1.0h or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround(s): Filter trafic to the administrative web interface, Disable the administrative web interface.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站