发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:36

[原文]Cross-site scripting (XSS) vulnerability in Goollery before 0.04b allows remote attackers to inject arbitrary HTML or web script via the conversation_id parameter to viewpic.php.


        Goollery 0.04b之前版本存在跨站脚本(XSS)漏洞。远程攻击者可以借助viewpic.php的conversation_id参数注入任意HTML或web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  OSVDB  11624

- 漏洞信息

中危 跨站脚本
2004-12-31 00:00:00 2005-10-20 00:00:00
        Goollery 0.04b之前版本存在跨站脚本(XSS)漏洞。远程攻击者可以借助viewpic.php的conversation_id参数注入任意HTML或web脚本。

- 公告与补丁


- 漏洞信息 (24718)

Goolery 0.3 viewpic.php conversation_id Parameter XSS (EDBID:24718)
php webapps
2004-11-02 Verified
0 Lostmon
N/A [点击下载]

It is reported that Goollery is affected by various cross-site scripting vulnerabilities. These issues are due to a failure of the application to properly sanitize user-supplied URI input. 

These problems present themselves when malicious HTML and script code is sent to the application through the 'page' parameter of several scripts. 

These issues could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user.<form%20action=""%20method="post">Username:<input%20na

- 漏洞信息

Goollery viewpic.php conversation_id Parameter XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Goollery contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the conversation_id variable upon submission to the viewpic.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of confidentiality and/or integrity.

- 时间线

2004-11-11 Unknow
2004-11-11 Unknow

- 解决方案

Upgrade to version 0.04b or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者