发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:35

[原文]Cross-site scripting (XSS) vulnerability in Goollery 0.03 allows remote attackers to inject arbitrary HTML or web script via the (1) page parameter to viewalbum.php or (2) btopage parameter to viewpic.php.


        Goollery 0.03版本存在跨站脚本攻击(XSS)漏洞。远程攻击者借助(1)viewalbum.php的page参数(2)viewpic.php的btopage参数注入任意HTML 或web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  OSVDB  11320
(PATCH)  OSVDB  11319
(UNKNOWN)  XF  goollery-viewalbum-viewpic-xss(17957)
(UNKNOWN)  BID  11587

- 漏洞信息

中危 跨站脚本
2004-12-31 00:00:00 2005-10-20 00:00:00
        Goollery 0.03版本存在跨站脚本攻击(XSS)漏洞。远程攻击者借助(1)viewalbum.php的page参数(2)viewpic.php的btopage参数注入任意HTML 或web脚本。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: .

- 漏洞信息 (24719)

Goolery 0.3 viewalbum.php page Parameter XSS (EDBID:24719)
php webapps
2004-11-02 Verified
0 Lostmon
N/A [点击下载]
It is reported that Goollery is affected by various cross-site scripting vulnerabilities. These issues are due to a failure of the application to properly sanitize user-supplied URI input.
These problems present themselves when malicious HTML and script code is sent to the application through the 'page' parameter of several scripts.
These issues could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user.<form%20action=""%20method="post">Username:<input%20name="us

- 漏洞信息

Goollery viewalbum.php page Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Goollery contains a flaw that may allow an attacker to perform cross-site scripting attacks. The issue is due to improper validation of user input passed to the viewalbum.php page variable. It is possible that the flaw may allow the attacker to execute arbitrary HTML or script code in the victim's browser in the security context of the affected site, resulting in a loss of integrity.

- 时间线

2004-10-31 Unknow
2004-10-31 Unknow

- 解决方案

Upgrade to version 0.04b or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者