CVE-2004-2240
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:35
NMCO    

[原文]Multiple SQL injection vulnerabilities in Phorum 5.0.11 and earlier allow remote attackers to modify SQL statements via (1) the query string in read.php or (2) unknown vectors in file.php.


[CNNVD]Phorum未明的跨站脚本和SQL注入漏洞(CNNVD-200412-989)

        Phorum 5.0.11及其以前的版本存在多个SQL注入漏洞。远程攻击者借助(1)read.php中的查询字符串或者(2)file.php中未知的向量修改SQL语句。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2240
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2240
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-989
(官方数据源) CNNVD

- 其它链接及资源

http://www.osvdb.org/11129
(PATCH)  OSVDB  11129
http://xforce.iss.net/xforce/xfdb/17847
(UNKNOWN)  XF  phorum-sql-injection(17847)
http://www.securityfocus.com/bid/11538
(UNKNOWN)  BID  11538
http://www.maxpatrol.com/mp_advisory.asp
(UNKNOWN)  MISC  http://www.maxpatrol.com/mp_advisory.asp
http://www.maxpatrol.com/advdetails.asp?id=15
(VENDOR_ADVISORY)  MISC  http://www.maxpatrol.com/advdetails.asp?id=15
http://securitytracker.com/id?1011921
(UNKNOWN)  SECTRACK  1011921
http://secunia.com/advisories/12980
(VENDOR_ADVISORY)  SECUNIA  12980
http://phorum.org/cvs-changelog-5.txt
(UNKNOWN)  CONFIRM  http://phorum.org/cvs-changelog-5.txt

- 漏洞信息

Phorum未明的跨站脚本和SQL注入漏洞
高危 SQL注入
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Phorum 5.0.11及其以前的版本存在多个SQL注入漏洞。远程攻击者借助(1)read.php中的查询字符串或者(2)file.php中未知的向量修改SQL语句。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息

11129
Phorum read.php Second Argument SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Vendor Verified

- 漏洞描述

Phorum contains a flaw that will allow a remote attacker to inject arbitrary SQL code. The problem is that the application does not validate user-supplied input upon submission to the 'read.php' script and will allow a remote attacker to inject or manipulate SQL queries.

- 时间线

2004-10-24 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 5.0.12 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站