发布时间 :2004-12-31 00:00:00
修订时间 :2017-07-10 21:31:43

[原文]SQL injection vulnerability in sql.php in the Glossary module in Moodle 1.4.1 and earlier allows remote attackers to modify SQL statements.

[CNNVD]Moodle Remote Glossary模块SQL注入漏洞(CNNVD-200412-150)

        Moodle 1.4.1及其早期版本的Glossary模块的sql.php存在SQL注入漏洞。远程攻击者可以利用该漏洞修改SQL语句。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:moodle:moodle:1.1.1Moodle 1.1.1
cpe:/a:moodle:moodle:1.2Moodle 1.2
cpe:/a:moodle:moodle:1.3.4Moodle 1.3.4
cpe:/a:moodle:moodle:1.3Moodle 1.3
cpe:/a:moodle:moodle:1.3.2Moodle 1.3.2
cpe:/a:moodle:moodle:1.4.1Moodle 1.4.1
cpe:/a:moodle:moodle:1.3.3Moodle 1.3.3
cpe:/a:moodle:moodle:1.2.1Moodle 1.2.1
cpe:/a:moodle:moodle:1.3.1Moodle 1.3.1

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  SECTRACK  1012113
(UNKNOWN)  BID  11608
(UNKNOWN)  XF  moodle-glossary-sql-injection(17965)

- 漏洞信息

Moodle Remote Glossary模块SQL注入漏洞
高危 SQL注入
2004-12-31 00:00:00 2005-10-20 00:00:00
        Moodle 1.4.1及其早期版本的Glossary模块的sql.php存在SQL注入漏洞。远程攻击者可以利用该漏洞修改SQL语句。

- 公告与补丁

        Although it has been reported that this issue is fixed in version 1.4.2 of the affected software, this is not confirmed. Please contact the vendor for more information.
        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: .

- 漏洞信息

Moodle Glossary Module sql.php SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

Moodle contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the sql.php script in the glossary module does not properly verify user-supplied input and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-09-28 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.4.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者