CVE-2004-2215
CVSS4.6
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:30
NMCO    

[原文]RXVT-Unicode 3.4 and 3.5 does not properly close file descriptors, which allows local users to access the terminals of other users and possibly gain privileges.


[CNNVD]RXVT-Unicode打开文件说明符泄露漏洞(CNNVD-200412-937)

        RXVT-Unicode 3.4版本和3.5版本不能正确地关闭文件说明符,本地用户可以访问其他用户的终端并且可能提升特权。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:marc_lehmann:rxvt-unicode:3.5
cpe:/a:marc_lehmann:rxvt-unicode:3.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2215
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2215
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-937
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/10959
(PATCH)  BID  10959
http://www.osvdb.org/8710
(PATCH)  OSVDB  8710
http://secunia.com/advisories/12299
(VENDOR_ADVISORY)  SECUNIA  12299
http://xforce.iss.net/xforce/xfdb/17000
(UNKNOWN)  XF  rxvt-unicode-open-file-handler(17000)
http://cvs.schmorp.de/browse/rxvt-unicode/Changes?view=markup
(UNKNOWN)  CONFIRM  http://cvs.schmorp.de/browse/rxvt-unicode/Changes?view=markup

- 漏洞信息

RXVT-Unicode打开文件说明符泄露漏洞
中危 设计错误
2004-12-31 00:00:00 2005-10-20 00:00:00
本地  
        RXVT-Unicode 3.4版本和3.5版本不能正确地关闭文件说明符,本地用户可以访问其他用户的终端并且可能提升特权。

- 公告与补丁

        The vendor has released version 3.6 to address this issue:
        Marc Lehmann RXVT-Unicode 3.4
        
        Marc Lehmann RXVT-Unicode 3.5
        

- 漏洞信息

8710
rxvt-unicode Arbitrary Terminal Window Access
Local Access Required Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

rxvt-unicode contains a flaw related to open filehandles that may allow an attacker to access arbitrary other terminal windows. No further details have been provided.

- 时间线

2004-08-13 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站