CVE-2004-2197
CVSS7.2
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:27
NMCO    

[原文]kdocker.cpp in kdocker 0.1 through 0.8 does not properly check the ownership of files, which could allow local users to execute arbitrary programs.


[CNNVD]KDocker未明漏洞(CNNVD-200412-582)

        kdocker 0.1至0.8版本的kdocker.cpp不能正确检查文件所有权。本地用户可以利用该漏洞执行任意程序。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:kdocker:kdocker:0.5
cpe:/a:kdocker:kdocker:0.6
cpe:/a:kdocker:kdocker:0.7
cpe:/a:kdocker:kdocker:0.3
cpe:/a:kdocker:kdocker:0.4
cpe:/a:kdocker:kdocker:0.1
cpe:/a:kdocker:kdocker:0.8
cpe:/a:kdocker:kdocker:0.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2197
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2197
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-582
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/17718
(PATCH)  XF  kdocker-kdockerccp-gain-privileges(17718)
http://www.securityfocus.com/bid/11419
(PATCH)  BID  11419
http://www.osvdb.org/10729
(PATCH)  OSVDB  10729
http://sourceforge.net/forum/forum.php?forum_id=414631
(PATCH)  CONFIRM  http://sourceforge.net/forum/forum.php?forum_id=414631
http://securitytracker.com/id?1011688
(PATCH)  SECTRACK  1011688
http://secunia.com/advisories/12828
(VENDOR_ADVISORY)  SECUNIA  12828
http://cvs.sourceforge.net/viewcvs.py/kdocker/kdocker/src/kdocker.cpp?r1=1.10&r2=1.11&sortby=log
(UNKNOWN)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/kdocker/kdocker/src/kdocker.cpp?r1=1.10&r2=1.11&sortby=log

- 漏洞信息

KDocker未明漏洞
高危 未知
2004-12-31 00:00:00 2005-10-20 00:00:00
本地  
        kdocker 0.1至0.8版本的kdocker.cpp不能正确检查文件所有权。本地用户可以利用该漏洞执行任意程序。

- 公告与补丁

        The vendor has released an upgrade to address this issue.
        kdocker kdocker 0.1
        
        kdocker kdocker 0.2
        
        kdocker kdocker 0.3
        
        kdocker kdocker 0.4
        
        kdocker kdocker 0.5
        
        kdocker kdocker 0.6
        
        kdocker kdocker 0.7
        
        kdocker kdocker 0.8
        

- 漏洞信息

10729
KDocker Permission Checking Issue
Local Access Required Authentication Management
Loss of Confidentiality
Exploit Public Vendor Verified

- 漏洞描述

KDocker contains a flaw related to the execution of files that may allow an attacker, authenticated to the X session, to send X client messages and have KDocker execute programs not owned by the owner of the KDocker process. No further details have been provided.

- 时间线

2004-10-14 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.9 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站