CVE-2004-2173
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:24
NMCO    

[原文]SQL injection vulnerability in advSearch_h.asp in EarlyImpact ProductCart allows remote attackers to execute arbitrary SQL commands via the priceUntil parameter.


[CNNVD]EarlyImpact ProductCart多个漏洞(CNNVD-200412-688)

        EarlyImpact ProductCart中的advSearch_h.asp存在SQL注入漏洞。远程攻击者可以借助priceUntil参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:early_impact:productcart:1.6003
cpe:/a:early_impact:productcart:2.5
cpe:/a:early_impact:productcart:1.6b002
cpe:/a:early_impact:productcart:1.6b003
cpe:/a:early_impact:productcart:1.5003
cpe:/a:early_impact:productcart:1.5004
cpe:/a:early_impact:productcart:2.0br000
cpe:/a:early_impact:productcart:1.6br003
cpe:/a:early_impact:productcart:1.6002
cpe:/a:early_impact:productcart:1.5002
cpe:/a:early_impact:productcart:1.5
cpe:/a:early_impact:productcart:1.6b001
cpe:/a:early_impact:productcart:1.6b
cpe:/a:early_impact:productcart:2.0
cpe:/a:early_impact:productcart:1.6br
cpe:/a:early_impact:productcart:1.6br001
cpe:/a:early_impact:productcart:1.5003r

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2173
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2173
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-688
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/9669
(PATCH)  BID  9669
http://xforce.iss.net/xforce/xfdb/15233
(VENDOR_ADVISORY)  XF  productcart-advsearchhasp-sql-injection(15233)
http://www.securityfocus.com/archive/1/354288
(UNKNOWN)  BUGTRAQ  20040216 EarlyImpact ProductCart shopping cart software multiple security vulnerabilities
http://www.s-quadra.com/advisories/Adv-20040216.txt
(UNKNOWN)  MISC  http://www.s-quadra.com/advisories/Adv-20040216.txt
http://www.osvdb.org/3981
(UNKNOWN)  OSVDB  3981
http://www.earlyimpact.com/productcart/support/updates/ReadMe_ProductCart_Security_Patch_013004.txt
(UNKNOWN)  CONFIRM  http://www.earlyimpact.com/productcart/support/updates/ReadMe_ProductCart_Security_Patch_013004.txt
http://securitytracker.com/alerts/2004/Feb/1009085.html
(UNKNOWN)  SECTRACK  1009085
http://secunia.com/advisories/10898
(UNKNOWN)  SECUNIA  10898
http://archives.neohapsis.com/archives/fulldisclosure/2004-02/0871.html
(UNKNOWN)  FULLDISC  20040216 EarlyImpact ProductCart shopping cart software multiple security vulnerabilities
http://archives.neohapsis.com/archives/bugtraq/2004-02/0503.html
(UNKNOWN)  BUGTRAQ  20040218 Re: EarlyImpact ProductCart shopping cart software multiple security vulnerabilities

- 漏洞信息

EarlyImpact ProductCart多个漏洞
高危 SQL注入
2004-12-31 00:00:00 2006-09-25 00:00:00
远程  
        EarlyImpact ProductCart中的advSearch_h.asp存在SQL注入漏洞。远程攻击者可以借助priceUntil参数执行任意SQL命令。

- 公告与补丁

        An upgrade is available that is not vulnerable to this issue.
        The vendor has released a security update to deal with this issue.
        
        EarlyImpact ProductCart 2.5
        

- 漏洞信息

3981
ProductCart advSearch_h.asp SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

ProductCart contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that input passed to certain parameters in "advSearch_h.asp" is not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-02-17 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, EarlyImpact has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站