CVE-2004-2171
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:23
NMCOE    

[原文]Cross-site scripting (XSS) vulnerability in Cherokee before 0.4.8 allows remote attackers to inject arbitrary web script or HTML via the URL, which is not properly quoted in the resulting error page.


[CNNVD]Cherokee错误页面跨站脚本攻击(XSS)漏洞(CNNVD-200412-1080)

        Cherokee 0.4.8存在跨站脚本攻击(XSS)漏洞。远程攻击者可以利用出错消息页面中未正确引用的URL注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:cherokee:cherokee_httpd:0.2
cpe:/a:cherokee:cherokee_httpd:0.1.5
cpe:/a:cherokee:cherokee_httpd:0.2.6
cpe:/a:cherokee:cherokee_httpd:0.2.5
cpe:/a:cherokee:cherokee_httpd:0.1
cpe:/a:cherokee:cherokee_httpd:0.4.7
cpe:/a:cherokee:cherokee_httpd:0.2.7
cpe:/a:cherokee:cherokee_httpd:0.4.6
cpe:/a:cherokee:cherokee_httpd:0.1.6

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2171
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2171
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-1080
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/9496
(VENDOR_ADVISORY)  BID  9496
http://www.osvdb.org/3707
(PATCH)  OSVDB  3707
http://secunia.com/advisories/10701/
(PATCH)  SECUNIA  10701
http://xforce.iss.net/xforce/xfdb/14936
(VENDOR_ADVISORY)  XF  cherokee-error-xss(14936)

- 漏洞信息

Cherokee错误页面跨站脚本攻击(XSS)漏洞
中危 跨站脚本
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Cherokee 0.4.8存在跨站脚本攻击(XSS)漏洞。远程攻击者可以利用出错消息页面中未正确引用的URL注入任意web脚本或HTML。

- 公告与补丁

        The vendor has provided an upgrade that has dealt with this issue.
        Cherokee Cherokee HTTPD 0.4.7
        

- 漏洞信息 (23605)

Cherokee 0.1.x/0.2.x/0.4.x Error Page Cross Site Scripting Vulnerability (EDBID:23605)
solaris remote
2004-01-26 Verified
0 César Fernández
N/A [点击下载]
source: http://www.securityfocus.com/bid/9496/info

Cherokee has been reported to contain a cross-site scripting vulnerability via error pages.

An attacker can exploit this issue by crafting a URI link containing the malevolent HTML or script code, and enticing a user to follow it. The attacker-supplied code may be rendered in the web browser of a user who follows the malicious link. Exploitation of this issue may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/<script>alert(document.cookie)</script> 		

- 漏洞信息

3707
Cherokee Web Server Error Page XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Cherokee webserver contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate invalid URLs before they are provided to the user in an error message. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-01-26 2004-01-26
Unknow Unknow

- 解决方案

Upgrade to version 0.4.8 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站