CVE-2004-2164
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:22
NMCO    

[原文]shoprestoreorder.asp in VP-ASP 5.0 does not close the database connection when a user restores a previous order, which allows remote attackers to cause a denial of service (connection consumption).


[CNNVD]Virtual Programming VP-ASP shoprestoreorder.asp远程拒绝服务漏洞(CNNVD-200412-403)

        
        Virtual Programming VP-ASP是一款商业性质的电子购物应用系统,由ASP脚本编写。
        VP-ASP 'shoprestoreorder.asp'脚本不正确处理数据库连接,远程攻击者可以利用这个漏洞对系统进行拒绝服务攻击。
        厂商报告远程用户可以使用'shoprestoreorder.asp'脚本恢复前一个订购,不过会导致数据库持续连接,多个此类连接可导致消耗大量数据库资源而产生拒绝服务。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2164
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2164
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-403
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/17436
(PATCH)  XF  vpasp-shoprestoreopenasp-dos(17436)
http://www.vpasp.com/virtprog/info/faq_securityfixes.htm
(PATCH)  CONFIRM  http://www.vpasp.com/virtprog/info/faq_securityfixes.htm
http://www.securitytracker.com/alerts/2004/Sep/1011359.html
(PATCH)  SECTRACK  1011359
http://www.securityfocus.com/bid/11228
(PATCH)  BID  11228
http://www.osvdb.org/10071
(UNKNOWN)  OSVDB  10071
http://secunia.com/advisories/12611
(UNKNOWN)  SECUNIA  12611

- 漏洞信息

Virtual Programming VP-ASP shoprestoreorder.asp远程拒绝服务漏洞
中危 其他
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        Virtual Programming VP-ASP是一款商业性质的电子购物应用系统,由ASP脚本编写。
        VP-ASP 'shoprestoreorder.asp'脚本不正确处理数据库连接,远程攻击者可以利用这个漏洞对系统进行拒绝服务攻击。
        厂商报告远程用户可以使用'shoprestoreorder.asp'脚本恢复前一个订购,不过会导致数据库持续连接,多个此类连接可导致消耗大量数据库资源而产生拒绝服务。
        

- 公告与补丁

        厂商补丁:
        Virtual Programming
        -------------------
        修改 'shoprestoreorder.asp'脚本:
        在If RestoreRedirecturl<>"" then
        Responseredirect RestoreRedirectUrl
        end if
        如下代码:
        If RestoreRedirecturl<>"" then
        Shopclosedatabase dbc
        Responseredirect RestoreRedirectUrl
        end if

- 漏洞信息

10071
VP-ASP Shopping Cart shoprestoreorder.asp Connection Persistence DoS
Remote / Network Access Denial of Service
Loss of Availability Patch / RCS
Exploit Unknown Vendor Verified

- 漏洞描述

VP-ASP contains a flaw that may allow a remote denial of service. The issue is triggered when an user uses shoprestoreorder.asp to restore a previous order and will result in loss of availability for the database.

- 时间线

2004-09-18 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, VP-ASP has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站