CVE-2004-2161
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:22
NMCOES    

[原文]SQL injection vulnerability in file_overview.php in TUTOS 1.1 allows remote attackers to execute arbitrary SQL commands via the link_id parameter.


[CNNVD]TUTOS远程SQL注入和跨站脚本执行漏洞(CNNVD-200412-1185)

        
        TUTOS是一款基于WEB的具有个人和组日志管理、bug跟踪、安装管理、任务列表、注释本、文件处理、邮件箱、链接等等功能的系统。
        TUTOS多处对用户提交的参数缺少充分过滤,远程攻击者可以利用这个漏洞获得敏感信息,或破坏数据库。
        Joxean Koret报告'/file/file_overview.php'脚本没有正确验证用户提供的'link_id'参数数据,如:
        http://[target]/file/file_overview.php?link_id=1005'asdf
        可导致SQL注入,造成数据库信息泄露或数据库破坏。
        另外'app_new.php'脚本没有过滤用户提供给't'变量的HTML代码,构建特殊的URL,诱使用户访问,可导致敏感信息泄露,如用于验证的COOKIE信息。
        另外搜索字段也没有正确过滤用户提供的HTML数据。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2161
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2161
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-1185
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/17444
(PATCH)  XF  tutos-sql-injection(17444)
http://secunia.com/advisories/12606/
(VENDOR_ADVISORY)  SECUNIA  12606
http://www.securityfocus.com/bid/11221
(UNKNOWN)  BID  11221
http://www.securityfocus.com/archive/1/375757
(VENDOR_ADVISORY)  BUGTRAQ  20040918 Vulnerabilities in TUTOS
http://cvs.sourceforge.net/viewcvs.py/tutos/tutos/php/file/file_overview.php?r1=1.11.2.1&r2=1.11.2.2
(UNKNOWN)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/tutos/tutos/php/file/file_overview.php?r1=1.11.2.1&r2=1.11.2.2
http://www.osvdb.org/10164
(UNKNOWN)  OSVDB  10164
http://www.debian.org/security/2006/dsa-980
(UNKNOWN)  DEBIAN  DSA-980
http://securitytracker.com/id?1011363
(UNKNOWN)  SECTRACK  1011363
http://secunia.com/advisories/18954
(UNKNOWN)  SECUNIA  18954

- 漏洞信息

TUTOS远程SQL注入和跨站脚本执行漏洞
高危 输入验证
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        TUTOS是一款基于WEB的具有个人和组日志管理、bug跟踪、安装管理、任务列表、注释本、文件处理、邮件箱、链接等等功能的系统。
        TUTOS多处对用户提交的参数缺少充分过滤,远程攻击者可以利用这个漏洞获得敏感信息,或破坏数据库。
        Joxean Koret报告'/file/file_overview.php'脚本没有正确验证用户提供的'link_id'参数数据,如:
        http://[target]/file/file_overview.php?link_id=1005'asdf
        可导致SQL注入,造成数据库信息泄露或数据库破坏。
        另外'app_new.php'脚本没有过滤用户提供给't'变量的HTML代码,构建特殊的URL,诱使用户访问,可导致敏感信息泄露,如用于验证的COOKIE信息。
        另外搜索字段也没有正确过滤用户提供的HTML数据。
        

- 公告与补丁

        厂商补丁:
        TUTOS
        -----
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载Tutos 1.2:
        
        http://www.tutos.org/homepage/download.html

- 漏洞信息 (24616)

TUTOS file_overview.php link_id Parameter SQL Injection (EDBID:24616)
php webapps
2004-09-20 Verified
0 Joxean Koret
N/A [点击下载]
source: http://www.securityfocus.com/bid/11221/info

Tutos is reported prone to multiple remote input-validation vulnerabilities. These issues exist due to insufficient sanitization of user-supplied data and may allow an attacker to carry out cross-site scripting and SQL-injection attacks. 

These issue reportedly affect Tutos 1.1.2004-04-14.

http://www.example.com/file/file_overview.php?link_id=1005'asdf 		

- 漏洞信息

10164
TUTOS file_overview.php link_id Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

TUTOS contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the link_id variable in the /file/file_overview.php?module is not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-09-18 Unknow
2004-09-18 Unknow

- 解决方案

Upgrade to version 1.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Tutos Multiple Remote Input Validation Vulnerabilities
Input Validation Error 11221
Yes No
2004-09-20 12:00:00 2006-07-11 10:58:00
Discovery is credited to Joxean Koret <joxeankoret@yahoo.es>.

- 受影响的程序版本

Tutos Tutos 1.1 .20040414
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1

- 漏洞讨论

Tutos is reported prone to multiple remote input-validation vulnerabilities. These issues exist due to insufficient sanitization of user-supplied data and may allow an attacker to carry out cross-site scripting and SQL-injection attacks.

These issue reportedly affect Tutos 1.1.2004-04-14.

- 漏洞利用

No exploit is required.

The following proof-of-concept examples are available:
http://www.example.com/file/file_overview.php?link_id=1005'asdf

http://www.example.com/app_new.php?t=200408240&lt;script&gt;alert(document.cookie)&lt;/script&gt;

- 解决方案

This issue has been addressed in the CVS.

Debian advisory DSA 980-1 is available to address these issues. Please see the referenced advisory for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站