CVE-2004-2160
CVSS6.4
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:21
NMCO    

[原文]Format string vulnerability in xml_elem.c for XMLStarlet Command Line XML Toolkit 0.9.3 may allow attackers to cause a denial of service or execute arbitrary code.


[CNNVD]xml_elem.c for XMLStarlet Command Line XML Toolkit xml_elem.c格式串漏洞(CNNVD-200412-269)

        xml_elem.c for XMLStarlet Command Line XML Toolkit 0.9.3版本的xml_elem.c存在格式串漏洞。远程攻击者利用该漏洞导致服务拒绝或者任意代码执行。

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2160
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2160
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-269
(官方数据源) CNNVD

- 其它链接及资源

http://sourceforge.net/project/shownotes.php?release_id=268962
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=268962
http://cvs.sourceforge.net/viewcvs.py/xmlstar/xmlstarlet/src/xml_elem.c?r1=1.17&r2=1.18
(UNKNOWN)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/xmlstar/xmlstarlet/src/xml_elem.c?r1=1.17&r2=1.18

- 漏洞信息

xml_elem.c for XMLStarlet Command Line XML Toolkit xml_elem.c格式串漏洞
中危 格式化字符串
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        xml_elem.c for XMLStarlet Command Line XML Toolkit 0.9.3版本的xml_elem.c存在格式串漏洞。远程攻击者利用该漏洞导致服务拒绝或者任意代码执行。

- 公告与补丁

        

- 漏洞信息

19128
XMLStarlet xml_elem.c Format String
Local / Remote, Context Dependent Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-09-10 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站