CVE-2004-2155
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:21
NMCOPS    

[原文]Online-bookmarks before 0.4.6 allows remote attackers to bypass its authentication mechanism via a direct request to (1) config/*, (2) bookmarks.php, (3) footer.php, (4) main.php, (5) tree.php, or (6) functions.php.


[CNNVD]在线书签认证绕过漏洞(CNNVD-200412-1197)

        Online-bookmarks 0.4.6之前的版本存在漏洞。远程攻击者借助(1) config/*, (2) bookmarks.php, (3) footer.php, (4) main.php, (5) tree.php,或(6) functions.php的直接请求绕过它的认证机制。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2155
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2155
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-1197
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/17602
(PATCH)  XF  online-bookmarks-resrtictions-bypass(17602)
http://www.securityfocus.com/bid/11305
(PATCH)  BID  11305
http://secunia.com/advisories/12728/
(VENDOR_ADVISORY)  SECUNIA  12728
http://freshmeat.net/projects/onlinebookmarks/?branch_id=34962&release_id=174401
(UNKNOWN)  CONFIRM  http://freshmeat.net/projects/onlinebookmarks/?branch_id=34962&release_id=174401

- 漏洞信息

在线书签认证绕过漏洞
高危 访问验证错误
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Online-bookmarks 0.4.6之前的版本存在漏洞。远程攻击者借助(1) config/*, (2) bookmarks.php, (3) footer.php, (4) main.php, (5) tree.php,或(6) functions.php的直接请求绕过它的认证机制。

- 公告与补丁

        The vendor has made online-bookmarks 0.4.6 available. Please see the references for details.
        online-bookmarks Web Based Bookmark Application 0.4
        
        online-bookmarks Web Based Bookmark Application 0.4.2
        
        online-bookmarks Web Based Bookmark Application 0.4.4
        

- 漏洞信息 (F73762)

Gentoo Linux Security Advisory 200901-8 (PacketStormID:F73762)
2009-01-12 00:00:00
Gentoo  security.gentoo.org
advisory,vulnerability
linux,gentoo
CVE-2004-2155,CVE-2006-6358,CVE-2006-6359
[点击下载]

Gentoo Linux Security Advisory GLSA 200901-08 - Multiple vulnerabilities have been reported in Online-Bookmarks. Versions less than 0.6.28 are affected.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200901-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                              http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

    Severity: Normal
       Title: Online-Bookmarks: Multiple vulnerabilities
        Date: January 12, 2009
        Bugs: #235053
          ID: 200901-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been reported in Online-Bookmarks.

Background
==========

Online-Bookmarks is a web-based bookmark management system to store
your bookmarks, favorites and links.

Affected packages
=================

      -------------------------------------------------------------------
       Package                    /  Vulnerable  /            Unaffected
      -------------------------------------------------------------------
    1  www-apps/online-bookmarks      < 0.6.28                 >= 0.6.28

Description
===========

The following vulnerabilities were reported:

* Authentication bypass when directly requesting certain pages
    (CVE-2004-2155).

* Insufficient input validation in the login function in auth.inc
    (CVE-2006-6358).

* Unspecified cross-site scripting vulnerability (CVE-2006-6359).

Impact
======

A remote attacker could exploit these vulnerabilities to bypass
authentication mechanisms, execute arbitrary SQL statements or inject
arbitrary web scripts.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Online-Bookmarks users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-apps/online-bookmarks-0.6.28"

References
==========

    [ 1 ] CVE-2004-2155
          http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2155
    [ 2 ] CVE-2006-6358
          http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-6358
    [ 3 ] CVE-2006-6359
          http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-6359

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

    http://security.gentoo.org/glsa/glsa-200901-08.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



    

- 漏洞信息

10484
Online Bookmarks PHP File Direct Request Content Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality
Exploit Public

- 漏洞描述

Online Bookmarks contains a flaw that may lead to an unauthorized information disclosure.  The issue is triggered when accessing the bookmarks.php, footer.php, main.php, tree.php, and functions.php in the 'config' directory directly, which will disclose content information resulting in a loss of confidentiality.

- 时间线

2004-10-04 Unknow
2004-10-04 Unknow

- 解决方案

Upgrade to version 0.4.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Online-Bookmarks Authentication Bypass Vulnerability
Access Validation Error 11305
Yes No
2004-10-01 12:00:00 2009-01-15 06:02:00
The individual responsible for the discovery of this issue is currently unknown; the vendor disclosed this issue.

- 受影响的程序版本

online-bookmarks Web Based Bookmark Application 0.4.4
online-bookmarks Web Based Bookmark Application 0.4.2
online-bookmarks Web Based Bookmark Application 0.4
Gentoo Linux
online-bookmarks Web Based Bookmark Application 0.4.6

- 不受影响的程序版本

online-bookmarks Web Based Bookmark Application 0.4.6

- 漏洞讨论

The online-bookmarks application is affected by an authentication-bypass vulnerability because it fails to properly manage unauthorized access to sensitive scripts.

An attacker may leverage these issues to gain unauthorized access to an unsuspecting user's bookmarks, allowing them to view, edit, and delete arbitrary entries.

- 漏洞利用

No exploit is required to leverage this issue.

- 解决方案

The vendor has made online-bookmarks 0.4.6 available. Please see the references for details.


online-bookmarks Web Based Bookmark Application 0.4

online-bookmarks Web Based Bookmark Application 0.4.2

online-bookmarks Web Based Bookmark Application 0.4.4

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站