发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:20

[原文]Cross-site scripting (XSS) vulnerability in 'raw' page output mode for MediaWiki 1.3.4 and earlier allows remote attackers to inject arbitrary web script or HTML.

[CNNVD]MediaWiki Raw Page跨站脚本漏洞(CNNVD-200412-685)

        MediaWiki 1.3.4及其以前版本的'raw'页面输出模式存在跨站脚本(XSS)漏洞。远程攻击者利用该漏洞注入任意web脚本或者HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mediawiki:mediawiki:1.3.3MediaWiki 1.3.3
cpe:/a:mediawiki:mediawiki:1.3.2MediaWiki 1.3.2
cpe:/a:mediawiki:mediawiki:1.2.5MediaWiki 1.2.5
cpe:/a:mediawiki:mediawiki:1.2.2MediaWiki 1.2.2
cpe:/a:mediawiki:mediawiki:1.3.1MediaWiki 1.3.1
cpe:/a:mediawiki:mediawiki:1.3.0MediaWiki 1.3.0
cpe:/a:mediawiki:mediawiki:1.2.4MediaWiki 1.2.4
cpe:/a:mediawiki:mediawiki:1.1.0MediaWiki 1.1.0
cpe:/a:mediawiki:mediawiki:1.2.1MediaWiki 1.2.1
cpe:/a:mediawiki:mediawiki:1.3.4MediaWiki 1.3.4
cpe:/a:mediawiki:mediawiki:1.2.0MediaWiki 1.2.0
cpe:/a:mediawiki:mediawiki:1.2.6MediaWiki 1.2.6
cpe:/a:mediawiki:mediawiki:1.2.3MediaWiki 1.2.3

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  XF  mediawiki-raw-output-xss(17578)
(PATCH)  BID  11302

- 漏洞信息

MediaWiki Raw Page跨站脚本漏洞
中危 跨站脚本
2004-12-31 00:00:00 2005-10-20 00:00:00
        MediaWiki 1.3.4及其以前版本的'raw'页面输出模式存在跨站脚本(XSS)漏洞。远程攻击者利用该漏洞注入任意web脚本或者HTML。

- 公告与补丁

        The vendor has released MediaWiki 1.3.5 to address this issue.
        MediaWiki MediaWiki 1.3
        MediaWiki MediaWiki 1.3.1
        MediaWiki MediaWiki 1.3.2
        MediaWiki MediaWiki 1.3.3
        MediaWiki MediaWiki 1.3.4

- 漏洞信息

MediaWiki raw Page Output Mode XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

MediaWiki contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate raw page output mode. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-09-30 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.3.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者