CVE-2004-2149
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:20
NMCO    

[原文]Buffer overflow in the prepared statements API in libmysqlclient for MySQL 4.1.3 beta and 4.1.4 allows remote attackers to cause a denial of service via a large number of placeholders.


[CNNVD]MySQL Bounded参数语句执行远程缓冲区溢出漏洞(CNNVD-200412-853)

        MySQL 4.1.3测试版和4.1.4版本的libmysqlclient的准备语句API存在缓冲区溢出漏洞。远程攻击者可以借助超多的占位符导致服务拒绝。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mysql:mysql:4.1.4MySQL MySQL 4.1.4
cpe:/a:mysql:mysql:4.1.3:betaMySQL MySQL 4.1.3 beta

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2149
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2149
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-853
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/11261
(PATCH)  BID  11261
http://securitytracker.com/id?1011408
(PATCH)  SECTRACK  1011408
http://xforce.iss.net/xforce/xfdb/17493
(UNKNOWN)  XF  mysql-libmysqlclient-insert-bo(17493)
http://www.osvdb.org/10244
(UNKNOWN)  OSVDB  10244
http://dev.mysql.com/doc/mysql/en/news-4-1-5.html
(UNKNOWN)  CONFIRM  http://dev.mysql.com/doc/mysql/en/news-4-1-5.html
http://bugs.mysql.com/bug.php?id=5194
(VENDOR_ADVISORY)  CONFIRM  http://bugs.mysql.com/bug.php?id=5194

- 漏洞信息

MySQL Bounded参数语句执行远程缓冲区溢出漏洞
中危 缓冲区溢出
2004-12-31 00:00:00 2006-03-28 00:00:00
远程  
        MySQL 4.1.3测试版和4.1.4版本的libmysqlclient的准备语句API存在缓冲区溢出漏洞。远程攻击者可以借助超多的占位符导致服务拒绝。

- 公告与补丁

        The vendor has released version 4.1.5 has been released to address this issue:
        MySQL AB MySQL 4.1.3 -beta
        
        MySQL AB MySQL 4.1.4
        

- 漏洞信息

10244
MySQL libmysqlclient Prepared Statements API Overflow
Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2004-09-16 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.1.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站