CVE-2004-2139
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2017-07-10 21:31:39
NMCO    

[原文]Unknown vulnerability in Adminedit.pl YaBB 1 Gold before 1.3.2 allows attackers to execute arbitrary code via settings.pl.


[CNNVD]YaBB 1 Gold多个输入验证漏洞(CNNVD-200412-257)

        Adminedit.pl YaBB 1 Gold 1.3.2以前的版本存在未知的漏洞。远程攻击者借助settings.pl执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:yabb:yabb:1_gold_-_sp_1.3.1
cpe:/a:yabb:yabb:1_gold_-_sp_1.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2139
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2139
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-257
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/11235
(UNKNOWN)  BID  11235
http://www.yabbforum.com/community/YaBB.pl?board=general;action=display;num=1093133233
(PATCH)  CONFIRM  http://www.yabbforum.com/community/YaBB.pl?board=general;action=display;num=1093133233
https://exchange.xforce.ibmcloud.com/vulnerabilities/17459
(UNKNOWN)  XF  yabb-admineditpl-xss(17459)

- 漏洞信息

YaBB 1 Gold多个输入验证漏洞
高危 输入验证
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Adminedit.pl YaBB 1 Gold 1.3.2以前的版本存在未知的漏洞。远程攻击者借助settings.pl执行任意代码。

- 公告与补丁

        The vendor has released an upgrade dealing with this issue.
        YaBB YaBB 1 Gold - SP 1.3.1
        
        YaBB YaBB 1 Gold - SP 1
        
        YaBB YaBB 1 Gold - SP 1.2
        
        YaBB YaBB 1 Gold - SP 1.3
        

- 漏洞信息

10222
YaBB Adminedit.pl Settings Arbitrary Code Execution
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Unknown Vendor Verified

- 漏洞描述

YaBB contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate an unspecified variable upon submission to the adminedit.pl script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-09-22 2004-08-21
Unknow Unknow

- 解决方案

Upgrade to version 1 GOLD SP 1.3.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站