CVE-2004-2130
CVSS4.3
发布时间 :2004-12-23 00:00:00
修订时间 :2016-10-17 23:06:47
NMCOES    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in privmsg.php in phpBB 2.0.6 allow remote attackers to execute arbitrary script or HTML via the (1) folder or (2) mode variables.


[CNNVD]phpBB Privmsg.PHP跨站脚本漏洞(CNNVD-200412-107)

        phpBB 2.0.6版本的privmsg.php存在多个跨站脚本(XSS)漏洞。远程攻击者借助(1)folder或者(2)mode变量执行任意脚本或者HTML。
        

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2130
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2130
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-107
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107530946123822&w=2
(UNKNOWN)  BUGTRAQ  20040128 phpBB privmsg.php XSS vulnerability patch.
http://www.phpbb.com/phpBB/viewtopic.php?f=14&t=161943
(VENDOR_ADVISORY)  CONFIRM  http://www.phpbb.com/phpBB/viewtopic.php?f=14&t=161943
http://www.securityfocus.com/bid/9290
(VENDOR_ADVISORY)  BID  9290

- 漏洞信息

phpBB Privmsg.PHP跨站脚本漏洞
中危 跨站脚本
2004-12-23 00:00:00 2005-10-20 00:00:00
远程  
        phpBB 2.0.6版本的privmsg.php存在多个跨站脚本(XSS)漏洞。远程攻击者借助(1)folder或者(2)mode变量执行任意脚本或者HTML。
        

- 公告与补丁

        The vendor has released phpBB 2.0.6c to address this and other issues. Users are advised to upgrade to the fixed version.
        phpBB Group phpBB 2.0.6
        

- 漏洞信息 (23475)

phpBB 2.0.6 Privmsg.PHP Cross-Site Scripting Vulnerability (EDBID:23475)
php webapps
2003-12-23 Verified
0 Ben Drysdale
N/A [点击下载]
source: http://www.securityfocus.com/bid/9290/info

phpBB is prone to a cross-site scripting vulnerability in the 'privmsg.php' script. The source of the problem is that HTML and script code are not adequately sanitized from input supplied via URI parameters. This input will be included in dynamically generated web pages. A remote attacker could exploit this issue by embedding hostile HTML and script code in a malicious link to the vulnerable script. The attacker-supplied code will be interpreted in the context of the site hosting the vulnerable software. 

http://www.example.com/forums/privmsg.php?mode=""><script>alert(document.cookie);</scrip
t>post&u=2

William Heatley has supplied the following proof of concept:
http://www.example.com/phpBB/privmsg.php?mode=%22%3E%3C%73%63%72%69%70%74%3E%61%6C%65%72%74%28%64%6F%63%75%6D%65%6E%74%2E%63%6F%6F%6B%69%65%29%3C%2F%73%63%72%69%70%74%3E%3C 		

- 漏洞信息

8165
phpBB privmsg.php mode Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpBB contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate user-supplied input in the 'privmsg.php' script using the 'mode' parameter. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-07-22 2004-07-20
2004-07-22 Unknow

- 解决方案

Upgrade to phpBB version 2.0.10 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

phpBB Privmsg.PHP Cross-Site Scripting Vulnerability
Input Validation Error 9290
Yes No
2003-12-23 12:00:00 2009-07-12 12:56:00
Discovery of this vulnerability has been credited to Ben Drysdale <ben@150bpm.co.uk>.

- 受影响的程序版本

phpBB Group phpBB 2.0.6
phpBB Group phpBB 2.0.6 c

- 不受影响的程序版本

phpBB Group phpBB 2.0.6 c

- 漏洞讨论

phpBB is prone to a cross-site scripting vulnerability in the 'privmsg.php' script. The source of the problem is that HTML and script code are not adequately sanitized from input supplied via URI parameters. This input will be included in dynamically generated web pages. A remote attacker could exploit this issue by embedding hostile HTML and script code in a malicious link to the vulnerable script. The attacker-supplied code will be interpreted in the context of the site hosting the vulnerable software.

- 漏洞利用

The following proof of concept has been supplied:

http://www.example.com/forums/privmsg.php?mode=""&gt;&lt;script&gt;alert(document.cookie);&lt;/scrip
t&gt;post&amp;u=2

William Heatley has supplied the following proof of concept:
http://www.example.com/phpBB/privmsg.php?mode=%22%3E%3C%73%63%72%69%70%74%3E%61%6C%65%72%74%28%64%6F%63%75%6D%65%6E%74%2E%63%6F%6F%6B%69%65%29%3C%2F%73%63%72%69%70%74%3E%3C

- 解决方案

The vendor has released phpBB 2.0.6c to address this and other issues. Users are advised to upgrade to the fixed version.


phpBB Group phpBB 2.0.6

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站