CVE-2004-2126
CVSS4.6
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:06:43
NMCOS    

[原文]The upgrade for BlackICE PC Protection 3.6 and earlier sets insecure permissions for .INI files such as (1) blackice.ini, (2) firewall.ini, (3) protect.ini, or (4) sigs.ini, which allows local users to modify BlackICE configuration or possibly execute arbitrary code by exploiting vulnerabilities in the .INI parsers.


[CNNVD]Internet Security Systems BlackICE PC保护升级文件权限漏洞(CNNVD-200412-727)

        BlackICE PC Protection 3.6及其以前版本的升级版为如(1)blackice.ini,(2)firewall.ini, (3)protect.ini,或者(4)sigs.ini的.INI文件设置不安全的权限,本地用户通过利用.INI解析器中的漏洞修改BlackICE配置或者可能执行任意代码。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2126
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2126
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-727
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107530966524193&w=2
(UNKNOWN)  BUGTRAQ  20040128 SRT2004-01-17-0227 - BlackICE allows local users to become SYSTEM
http://www.securityfocus.com/bid/9513
(UNKNOWN)  BID  9513

- 漏洞信息

Internet Security Systems BlackICE PC保护升级文件权限漏洞
中危 配置错误
2004-12-31 00:00:00 2005-10-20 00:00:00
本地  
        BlackICE PC Protection 3.6及其以前版本的升级版为如(1)blackice.ini,(2)firewall.ini, (3)protect.ini,或者(4)sigs.ini的.INI文件设置不安全的权限,本地用户通过利用.INI解析器中的漏洞修改BlackICE配置或者可能执行任意代码。

- 公告与补丁

        The vendor has reportedly released a fix. This has not been confirmed by Symantec. Affected users should contact the vendor to determine the availability of fixes.

- 漏洞信息

8701
BlackICE/PC Protection Configuration File Insecure Permissions
Local Access Required Misconfiguration
Loss of Integrity
Exploit Public

- 漏洞描述

BlackIce/PC Protection contains a flaw that may allow a local attacker to modify program settings. The issue is due to the several key configuration files being installed with everyone/full access privileges. The firewall.ini, blackice.ini and sigs.ini configuration files each contain critical options and rules that significantly alter the program behavior. By editing these files, an attacker could edit rules that govern system traffic and more.

- 时间线

2004-08-14 Unknow
2004-08-14 Unknow

- 解决方案

Currently, there are no known upgrades or patches to correct this issue. It is possible to correct the flaw by implementing the following workaround(s): Immediately after installation, change privileges so that only authorized users can modify firewall.ini, blackice.ini and sigs.ini configuration files.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Internet Security Systems BlackICE PC Protection Upgrade File Permission Vulnerability
Configuration Error 9513
No Yes
2004-01-28 12:00:00 2009-07-12 02:06:00
Discovery is credited to Secure Network Operations.

- 受影响的程序版本

Internet Security Systems BlackICE PC Protection 3.6 .cbz

- 漏洞讨论

BlackICE PC Protection is reported to install various .ini files with insecure permissions after an upgrade. This may allow non-administrative users to modify or replace these files, facilitating other attacks. This could affect various security properties as configuration information for the software may be altered by an unauthorized user. There is also a buffer overrun that exists in the software when parsing various directives included in .ini files, as described in BID 9514. This additional issue could be exploited once the permissions have been lowered.

It should be noted that exploitation of other latent vulnerabilities, such as those described in BID 8577 could create a situation where a remote attacker could place a hostile .ini on the local file system that is designed to weaken the security provided by the software or exploit the buffer overrun described in BID 9514.

This issue has been reported to occur when the software is upgraded to version 3.6.cbz.

- 漏洞利用

There is no exploit required for this vulnerability.

- 解决方案

The vendor has reportedly released a fix. This has not been confirmed by Symantec. Affected users should contact the vendor to determine the availability of fixes.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站