CVE-2004-2124
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:06:40
NMCOE    

[原文]The register_globals simulation capability in Gallery 1.3.1 through 1.4.1 allows remote attackers to modify the HTTP_POST_VARS variable and conduct a PHP remote file inclusion attack via the GALLERY_BASEDIR parameter, a different vulnerability than CVE-2002-1412.


[CNNVD]Gallery远程全局变量注入漏洞(CNNVD-200412-575)

        Gallery 1.3.1至1.4.1版本的register_globals 仿真性能存在漏洞。远程攻击者可以借助GALLERY_BASEDIR参数修改和执行PHP remote file inclusion攻击修改HTTP_POST_VARS变量。该漏洞不同于CVE-2002-1412。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:gallery_project:gallery:1.3.2
cpe:/a:gallery_project:gallery:1.4.1
cpe:/a:gallery_project:gallery:1.3.3
cpe:/a:gallery_project:gallery:1.4
cpe:/a:gallery_project:gallery:1.3.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2124
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2124
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-575
(官方数据源) CNNVD

- 其它链接及资源

http://gallery.menalto.com/modules.php?op=modload&name=News&file=index
(PATCH)  CONFIRM  http://gallery.menalto.com/modules.php?op=modload&name=News&file=index
http://marc.info/?l=bugtraq&m=107524414317693&w=2
(UNKNOWN)  BUGTRAQ  20040127 Remote exploit in Gallery 1.3.1, 1.3.2, 1.3.3, 1.4 and 1.4.1
http://www.gentoo.org/security/en/glsa/glsa-200402-04.xml
(UNKNOWN)  GENTOO  GLSA-200402-04
http://www.securityfocus.com/bid/9490
(UNKNOWN)  BID  9490
http://xforce.iss.net/xforce/xfdb/14950
(UNKNOWN)  XF  gallery-gallerybasedir-file-include(14950)

- 漏洞信息

Gallery远程全局变量注入漏洞
中危 输入验证
2004-12-31 00:00:00 2006-09-28 00:00:00
远程  
        Gallery 1.3.1至1.4.1版本的register_globals 仿真性能存在漏洞。远程攻击者可以借助GALLERY_BASEDIR参数修改和执行PHP remote file inclusion攻击修改HTTP_POST_VARS变量。该漏洞不同于CVE-2002-1412。

- 公告与补丁

        The vendor has released Gallery 1.4.1-pl1 to address this issue. Users are advised to upgrade to the fixed version.
        Gentoo has released advisory GLSA 200402-04 dealing with this issue. Please see the reference section for details.
        The vendor has released Gallery 1.4.2 to address this and other issues. It is advised that if possible, users should upgrade to this version.
        Bharat Mediratta Gallery 1.3.1
        
        Bharat Mediratta Gallery 1.3.2
        
        Bharat Mediratta Gallery 1.3.3
        
        Bharat Mediratta Gallery 1.4
        
        Bharat Mediratta Gallery 1.4.1
        

- 漏洞信息 (23599)

Gallery 1.3.x/1.4 Remote Global Variable Injection Vulnerability (EDBID:23599)
php webapps
2004-01-26 Verified
0 Bharat Mediratta
N/A [点击下载]
source: http://www.securityfocus.com/bid/9490/info

It has been reported that Gallery is prone to a vulnerability that may allow a remote attacker to gain unauthorized access by overwriting various values for global variables. The issue occurs due to improper simulation of the behaviour of register_globals when the register_globals settings is disabled. It has been reported that register_globals functionality is simulated by extracting the values of the various $HTTP_ global variables into the global namespace. Due to improper sanitization of user-supplied data, an attacker may be able to overwrite the value of 'HTTP_POST_VARS' via the register_global simulation. Arbitrary PHP files may be included via the 'GALLERY_BASEDIR' parameter.

The vendor has reported that this issue exists in Gallery versions 1.3.1, 1.3.2, 1.3.3, 1.4 and 1.4.1. 

http://www.example.com/gallery/init.php?HTTP_POST_VARS=xxx 		

- 漏洞信息

3737
Gallery HTTP Global Variables File Inclusion

- 漏洞描述

Gallery contains a flaw that may allow a malicious user to remotely execute code on the web server. The issue is caused by a failure to validate variables in HTTP requests. It is possible that the flaw may allow arbitrary code execution resulting in a loss of confidentiality, integrity, and/or availability.

- 时间线

2004-01-24 2004-01-24
Unknow Unknow

- 解决方案

Upgrade to version 1.41-pl1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站