CVE-2004-2109
CVSS6.8
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:06:21
NMCOS    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in (1) imagezoom.asp or (2) recommend.asp in Q-Shop allow remote attackers to execute arbitrary script and steal the user session ID via Javascript in a URL.


[CNNVD]QuadComm Q-Shop跨站脚本漏洞(CNNVD-200412-466)

        Q-Shop中的(1)imagezoom.asp或(2)recommend.asp存在多个跨站脚本漏洞。远程攻击者可以借助URL中的Javascript执行任意脚本以及窃取用户会话ID。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:quadcomm:q-shop:2.0
cpe:/a:quadcomm:q-shop:2.1
cpe:/a:quadcomm:q-shop:2.5
cpe:/a:quadcomm:q-shop:2.5_beta

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2109
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2109
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-466
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107488132208229&w=2
(UNKNOWN)  BUGTRAQ  20040123 QuadComm Q-Shop ASP Shopping Cart Software multiple security vulnerabilities
http://www.securityfocus.com/bid/9480
(PATCH)  BID  9480
http://xforce.iss.net/xforce/xfdb/14923
(UNKNOWN)  XF  qshop-url-xss(14923)

- 漏洞信息

QuadComm Q-Shop跨站脚本漏洞
中危 跨站脚本
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Q-Shop中的(1)imagezoom.asp或(2)recommend.asp存在多个跨站脚本漏洞。远程攻击者可以借助URL中的Javascript执行任意脚本以及窃取用户会话ID。

- 公告与补丁

        A fix Q-SHOP Euro (italian version of Q-SHOP) has been provided. Users may download the fix from the following location:
        http://www.q-shop.it/patch/QSE_FIX_2004_01_26.zip

- 漏洞信息

3696
QuadComm Q-Shop imagezoom.asp XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Quadcomm Q-Shop contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate user input upon submission to the imagezoom.asp script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-01-26 2004-01-26
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

QuadComm Q-Shop Cross Site Scripting Vulnerabilities
Input Validation Error 9480
Yes No
2004-01-23 12:00:00 2009-07-12 02:06:00
Discovery of this issue has been credited to Nick Gudov <cipher@s-quadra.com>.

- 受影响的程序版本

QuadComm Q-Shop 2.5 beta
QuadComm Q-Shop 2.5
QuadComm Q-Shop 2.1
QuadComm Q-Shop 2.0

- 漏洞讨论

Q-Shop has been reported to contain multiple cross-site scripting vulnerabilities. This issue is due to the application failing to perform proper sanitization of values passed through URI parameters. An attacker may exploit these issues by enticing a victim user to follow a malicious link that includes embedded hostile HTML and script code.

- 漏洞利用

There is no exploit required.

- 解决方案

A fix Q-SHOP Euro (italian version of Q-SHOP) has been provided. Users may download the fix from the following location:

http://www.q-shop.it/patch/QSE_FIX_2004_01_26.zip

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站