发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:06:14

[原文]Cross-site scripting (XSS) vulnerability in Novell NetWare Enterprise Web Server 5.1 and 6.0 allows remote attackers to process arbitrary script or HTML as other users via (1) a malformed request for a Perl program with script in the filename, (2) the parameter to the webacc servlet, (3) the GWAP.version parameter to webacc, or (4) a URL request for a .bas file with script in the filename.

[CNNVD]Novell NetWare Enterprise Web服务器跨站脚本(XSS)漏洞 (CNNVD-200412-897)

        Novell NetWare Enterprise Web服务器5.1和6.0版本存在跨站脚本(XSS)漏洞。远程攻击者可以借助(1)带有文件名脚本的Perl程序的畸形请求,(2)webacc servlet的User.id参数,(3)webacc的GWAP.version参数或(4)带有文件名脚本的URL请求与其他用户一样处理任意脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20040123 NetWare-Enterprise-Web-Server/5.1/6.0 Multiple Vulnerabilities
(UNKNOWN)  XF  netware-enterprise-cgi2perl-xss(14919)

- 漏洞信息

Novell NetWare Enterprise Web服务器跨站脚本(XSS)漏洞
中危 跨站脚本
2004-12-31 00:00:00 2009-07-02 00:00:00
        Novell NetWare Enterprise Web服务器5.1和6.0版本存在跨站脚本(XSS)漏洞。远程攻击者可以借助(1)带有文件名脚本的Perl程序的畸形请求,(2)webacc servlet的User.id参数,(3)webacc的GWAP.version参数或(4)带有文件名脚本的URL请求与其他用户一样处理任意脚本或HTML。

- 公告与补丁


- 漏洞信息

Novell NetWare Enterprise Web Server webacc Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Novell NetWare Enterprise Web Server / GroupWise contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the '' or 'GWAP.version' variables upon submission to the 'webacc' utility. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-01-06 Unknow
2004-01-06 Unknow

- 解决方案

Upgrade to version CSP 8 for 5.1, CSP 5 for 6.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者