CVE-2004-2094
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:06:03
NMCOES    

[原文]Cross-site scripting (XSS) vulnerability in WebcamXP 1.06.945 allows remote attackers to inject arbitrary HTML or web script as other users via a URL that contains the script.


[CNNVD]Darkwet Network WebcamXP跨站脚本漏洞(CNNVD-200412-261)

        WebcamXP 1.06.945版本中存在跨站脚本(XSS)漏洞。远程攻击者可以如其他用户样借助含有脚本的URL注入任意HTML或者web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2094
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2094
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-261
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107471195326270&w=2
(UNKNOWN)  BUGTRAQ  20040121 WebcamXP v1.06.945 Cross Site Scripting Vulnerabillity
http://www.securityfocus.com/bid/9465
(UNKNOWN)  BID  9465
http://xforce.iss.net/xforce/xfdb/14904
(UNKNOWN)  XF  webcamxp-xss(14904)

- 漏洞信息

Darkwet Network WebcamXP跨站脚本漏洞
中危 跨站脚本
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        WebcamXP 1.06.945版本中存在跨站脚本(XSS)漏洞。远程攻击者可以如其他用户样借助含有脚本的URL注入任意HTML或者web脚本。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息 (23563)

Darkwet Network WebcamXP 1.6.945 Cross-Site Scripting Vulnerability (EDBID:23563)
multiple remote
2004-01-21 Verified
0 Rafel Ivgi The-Insider
N/A [点击下载]
source: http://www.securityfocus.com/bid/9465/info

It has been reported that WebcamXP may be prone to a cross-site scripting vulnerability that may allow a remote attacker to execute HTML or script code in a user's browser. It has been reported that HTML and script code may be parsed via a malicious URI.

Successful exploitation of this attack may allow an attacker to steal cookie-based authentication credentials. Other attacks are also possible. 

WebcamXP version 1.06.945 has been identified as vulnerable, however, other versions could be affected as well.

http://www.example.com/<script>alert('XSS')</script>		

- 漏洞信息

38235
WebcamXP Unspecified Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-01-21 Unknow
2004-01-21 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Darkwet Network WebcamXP Cross-Site Scripting Vulnerability
Input Validation Error 9465
Yes No
2004-01-21 12:00:00 2009-07-12 02:06:00
The disclosure of this issue has been credited to Rafel Ivgi, The-Insider <theinsider@012.net.il>.

- 受影响的程序版本

Darkwet WebCam XP 1.6.945

- 漏洞讨论

It has been reported that WebcamXP may be prone to a cross-site scripting vulnerability that may allow a remote attacker to execute HTML or script code in a user's browser. It has been reported that HTML and script code may be parsed via a malicious URI.

Successful exploitation of this attack may allow an attacker to steal cookie-based authentication credentials. Other attacks are also possible.

WebcamXP version 1.06.945 has been identified as vulnerable, however, other versions could be affected as well.

- 漏洞利用

No exploit is required.

The following proof of concept has been supplied:

http://www.example.com/&lt;script&gt;alert('XSS')&lt;/script&gt;

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站