CVE-2004-2085
CVSS4.3
发布时间 :2004-02-04 00:00:00
修订时间 :2008-09-05 16:43:09
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in Brad Fears phpCodeCabinet 0.4 and earlier allow remote attackers to inject arbitrary web script or HTML via multiple parameters, including (1) the sid parameter to comments.php, (2) the cid, cf, or rfd parameters to category.php, or the cid parameter to (3) input.php, (4) browse.php, (5) themes/facade/header.php, or (6) themes/phpcc/header.php.


[CNNVD]Brad Fears PHPCodeCabinet comments.php HTML注入漏洞(CNNVD-200402-027)

        Brad Fears phpCodeCabinet 0.4及其以前版本存在多个跨站脚本(XSS)漏洞。远程攻击者可以通过多种参数注入任意的web脚本或者HTML,这些参数包含(1)comments.php中的sid参数(2)category.php中的cid, cf或者rfd参数,或(3) input.php, (4) browse.php, (5) themes/facade/header.php, 或者(6) themes/phpcc/header.php中的cid参数。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:brad_fears:phpcodecabinet:0.3
cpe:/a:brad_fears:phpcodecabinet:0.2
cpe:/a:brad_fears:phpcodecabinet:0.1
cpe:/a:brad_fears:phpcodecabinet:0.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2085
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2085
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200402-027
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/15190
(VENDOR_ADVISORY)  XF  phpcodecabinet-multiple-xss(15190)
http://www.securityfocus.com/bid/9645
(VENDOR_ADVISORY)  BID  9645
http://www.securityfocus.com/bid/9601
(VENDOR_ADVISORY)  BID  9601
http://www.osvdb.org/3887
(VENDOR_ADVISORY)  OSVDB  3887
http://www.osvdb.org/3886
(VENDOR_ADVISORY)  OSVDB  3886
http://www.osvdb.org/3885
(VENDOR_ADVISORY)  OSVDB  3885
http://sourceforge.net/project/shownotes.php?release_id=214860
(VENDOR_ADVISORY)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=214860
http://cvs.sourceforge.net/viewcvs.py/phpcodecabinet/phpcc/themes/phpcc/header.php?r1=1.4&r2=1.5
(VENDOR_ADVISORY)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/phpcodecabinet/phpcc/themes/phpcc/header.php?r1=1.4&r2=1.5
http://cvs.sourceforge.net/viewcvs.py/phpcodecabinet/phpcc/themes/facade/header.php?r1=1.4&r2=1.5
(VENDOR_ADVISORY)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/phpcodecabinet/phpcc/themes/facade/header.php?r1=1.4&r2=1.5
http://cvs.sourceforge.net/viewcvs.py/phpcodecabinet/phpcc/input.php?r1=1.7&r2=1.8
(VENDOR_ADVISORY)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/phpcodecabinet/phpcc/input.php?r1=1.7&r2=1.8
http://cvs.sourceforge.net/viewcvs.py/phpcodecabinet/phpcc/comments.php?r1=1.1&r2=1.2
(VENDOR_ADVISORY)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/phpcodecabinet/phpcc/comments.php?r1=1.1&r2=1.2
http://cvs.sourceforge.net/viewcvs.py/phpcodecabinet/phpcc/category.php?r1=1.4&r2=1.5
(VENDOR_ADVISORY)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/phpcodecabinet/phpcc/category.php?r1=1.4&r2=1.5
http://cvs.sourceforge.net/viewcvs.py/phpcodecabinet/phpcc/browse.php?r1=1.5&r2=1.6
(VENDOR_ADVISORY)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/phpcodecabinet/phpcc/browse.php?r1=1.5&r2=1.6
http://www.osvdb.org/16711
(UNKNOWN)  OSVDB  16711
http://www.osvdb.org/16710
(UNKNOWN)  OSVDB  16710
http://securitytracker.com/id?1009012
(UNKNOWN)  SECTRACK  1009012
http://secunia.com/advisories/10862
(UNKNOWN)  SECUNIA  10862

- 漏洞信息

Brad Fears PHPCodeCabinet comments.php HTML注入漏洞
中危 跨站脚本
2004-02-04 00:00:00 2005-10-20 00:00:00
远程  
        Brad Fears phpCodeCabinet 0.4及其以前版本存在多个跨站脚本(XSS)漏洞。远程攻击者可以通过多种参数注入任意的web脚本或者HTML,这些参数包含(1)comments.php中的sid参数(2)category.php中的cid, cf或者rfd参数,或(3) input.php, (4) browse.php, (5) themes/facade/header.php, 或者(6) themes/phpcc/header.php中的cid参数。

- 公告与补丁

        The vendor has released phpCodeCabinet 0.5 to address this issue. Users are advised to download the fixed version.
        Brad Fears phpCodeCabinet 0.2
        
        Brad Fears phpCodeCabinet 0.3
        
        Brad Fears phpCodeCabinet 0.4
        

- 漏洞信息

16710
phpCodeCabinet (phpCC) facade/header.php Script Injection
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

phpCodeCabinet contains flaws that allows remote cross site scripting attacks. This flaw exists because the application does not validate unspecified variables upon submission to the themes/facade/header.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-02-04 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站