CVE-2004-2084
CVSS4.3
发布时间 :2004-02-07 00:00:00
修订时间 :2008-09-05 16:43:09
NMCOE    

[原文]Cross-site scripting (XSS) vulnerability in search.php in JShop E-Commerce Server allows remote attackers to inject arbitrary web script or HTML via the xSearch parameter.


[CNNVD]JShop E-Commerce Suite xSearch 跨站脚本漏洞(CNNVD-200402-031)

        JShop E-Commerce服务器中的search.php存在跨站脚本(XSS)漏洞。远程攻击者可以通过xSearch参数注入任意的 web脚本或者HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:jshop_e-commerce:jshop_server:1.0.1
cpe:/a:jshop_e-commerce:jshop_server:1.1.0
cpe:/a:jshop_e-commerce:jshop_professional:3.3
cpe:/a:jshop_e-commerce:jshop_server:1.0.2
cpe:/a:jshop_e-commerce:jshop_professional:3.4
cpe:/a:jshop_e-commerce:jshop_server:1.0.3
cpe:/a:jshop_e-commerce:jshop_professional:3.2
cpe:/a:jshop_e-commerce:jshop_professional:3.1
cpe:/a:jshop_e-commerce:jshop_server:1.2.0
cpe:/a:jshop_e-commerce:jshop_server:1.0.4
cpe:/a:jshop_e-commerce:jshop_professional:3.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2084
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2084
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200402-031
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/15100
(VENDOR_ADVISORY)  XF  jshop-searchphp-xss(15100)
http://www.osvdb.org/3889
(PATCH)  OSVDB  3889
http://www.systemsecure.org/advisories/ssadvisory09022004.php
(VENDOR_ADVISORY)  MISC  http://www.systemsecure.org/advisories/ssadvisory09022004.php
http://www.securityfocus.com/bid/9609
(VENDOR_ADVISORY)  BID  9609
http://securitytracker.com/id?1008988
(VENDOR_ADVISORY)  SECTRACK  1008988
http://secunia.com/advisories/10825
(VENDOR_ADVISORY)  SECUNIA  10825

- 漏洞信息

JShop E-Commerce Suite xSearch 跨站脚本漏洞
中危 跨站脚本
2004-02-07 00:00:00 2005-10-20 00:00:00
远程  
        JShop E-Commerce服务器中的search.php存在跨站脚本(XSS)漏洞。远程攻击者可以通过xSearch参数注入任意的 web脚本或者HTML。

- 公告与补丁

        It has been reported that a vendor supplied fix to address this issue is pending. This however has not been confirmed.
        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息 (23666)

JShop E-Commerce Suite xSearch Cross-Site Scripting Vulnerability (EDBID:23666)
php webapps
2004-02-09 Verified
0 David Sopas Ferreira
N/A [点击下载]
source: http://www.securityfocus.com/bid/9609/info

A vulnerability has been reported to exist in JShop E-Commerce that may allow a remote user to execute HTML or script code in a user's browser.

The issue is reported to exist due to improper sanitizing of user-supplied data. It has been reported that HTML and script code may be parsed via a URI parameter of the 'search.php' script. This vulnerability makes it possible for an attacker to construct a malicious link containing HTML or script code that may be rendered in a user's browser upon visiting that link. This attack would occur in the security context of the site.

search.php?xSearch=%3Cscript%3Ealert%28document.domain%29%3B%3C%2Fscrip%3E&submit=Search		

- 漏洞信息

3889
JShop Server xSearch XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

JShop contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "xSearch" variable upon submission to the search.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-02-10 2004-02-10
Unknow Unknow

- 解决方案

Upgrade to the latest version, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站