CVE-2004-2067
CVSS7.5
发布时间 :2004-07-29 00:00:00
修订时间 :2016-10-17 23:05:55
NMCOE    

[原文]SQL injection vulnerability in controlpanel.php in Jaws Framework and Content Management System 0.4 allows remote attackers to execute arbitrary SQL and bypass authentication via the (1) user, (2) password, or (3) crypted_password parameters.


[CNNVD]JAWS ControlPanel.php SQL注入漏洞(CNNVD-200407-096)

        
        Jaws是一款动态构建WEB站点的内容管理系统。
        Jaws controlpanel.php脚本不正确处理用户提交的URI参数,远程攻击者可以利用这个漏洞无需要提供密码访问管理员控制面版。
        由于controlpanel.php脚本对用户提交给"crypted_password"变量缺少正确的逻辑检查,攻击者提交类似''' or '2'='2''的数据,可导致逻辑错误,无需提供正确密码通过验证访问应用程序管理面版。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:jaws:jaws:0.4
cpe:/a:jaws:jaws:0.3
cpe:/a:jaws:jaws:0.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2067
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2067
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200407-096
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=109116345930380&w=2
(UNKNOWN)  BUGTRAQ  20040729 Jaws 0.4: authentication bypass
http://securitytracker.com/id?1010815
(UNKNOWN)  SECTRACK  1010815
http://www.securityfocus.com/bid/10826
(VENDOR_ADVISORY)  BID  10826
http://xforce.iss.net/xforce/xfdb/16847
(VENDOR_ADVISORY)  XF  jaws-controlpanel-sql-injection(16847)

- 漏洞信息

JAWS ControlPanel.php SQL注入漏洞
高危 输入验证
2004-07-29 00:00:00 2006-06-15 00:00:00
远程  
        
        Jaws是一款动态构建WEB站点的内容管理系统。
        Jaws controlpanel.php脚本不正确处理用户提交的URI参数,远程攻击者可以利用这个漏洞无需要提供密码访问管理员控制面版。
        由于controlpanel.php脚本对用户提交给"crypted_password"变量缺少正确的逻辑检查,攻击者提交类似''' or '2'='2''的数据,可导致逻辑错误,无需提供正确密码通过验证访问应用程序管理面版。
        

- 公告与补丁

        厂商补丁:
        JAWS
        ----
        目前CVS版本已经修补此问题,请到厂商的主页下载:
        
        http://www.jaws.com.mx/

- 漏洞信息 (24334)

JAWS 0.2/0.3/0.4 ControlPanel.PHP SQL Injection Vulnerability (EDBID:24334)
php webapps
2004-07-29 Verified
0 Fernando Quintero
N/A [点击下载]
source: http://www.securityfocus.com/bid/10826/info

JAWS is reportedly affected by a remote SQL injection vulnerability. This issue occurs in the controlpanel.php script due to a failure of the application to properly sanitize user-supplied URI parameter input before using it in an SQL query.

Because of this, a malicious user may influence database queries in order to view or modify sensitive information, potentially compromising the software or the database.

<script type="text/javascript">

function crypt_form(form) {
var new_password = calcMD5(form.password.value);
form.crypted_password.value = "' or '2'='2";
form.password.value = "";
return true;
}
</script>		

- 漏洞信息

8320
JAWS controlpanel.php crypted_password Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

JAWS contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the crypted_password variable in the controlpanel.php module is not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-07-29 Unknow
2004-07-29 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, JAWS has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站