CVE-2004-2066
CVSS7.5
发布时间 :2004-07-29 00:00:00
修订时间 :2016-10-17 23:05:54
NMCO    

[原文]SQL injection vulnerability in session.php in LinPHA 0.9.4 allows remote attackers to execute arbitrary SQL code and bypass authentication via the (1) linpha_userid or (2) linpha_password cookies.


[CNNVD]Linpha远程验证绕过漏洞(CNNVD-200407-097)

        
        LinPHA是一款基于WEB的图象照片库管理程序。
        LinPHA在通过COOKIE进行验证时存在问题,远程攻击者可以利用这个漏洞未授权访问系统。
        问题存在于session.php文件中,由于对linpha_userid和linpha_password COOKIE信息验证处理不正确,攻击者可以修改会话的COOKIE信息,不需要密码访问LinPHA系统。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:linpha:linpha:0.9.3
cpe:/a:linpha:linpha:0.9.4
cpe:/a:linpha:linpha:0.9.1
cpe:/a:linpha:linpha:0.9.2
cpe:/a:linpha:linpha:0.9.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2066
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2066
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200407-097
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=109112246805277&w=2
(UNKNOWN)  BUGTRAQ  20040729 Linpha 0.9.4: authentication bypass
http://www.securityfocus.com/bid/10827
(VENDOR_ADVISORY)  BID  10827
http://xforce.iss.net/xforce/xfdb/16834
(VENDOR_ADVISORY)  XF  linpha-cookie-gain-access(16834)

- 漏洞信息

Linpha远程验证绕过漏洞
高危 输入验证
2004-07-29 00:00:00 2005-10-20 00:00:00
远程  
        
        LinPHA是一款基于WEB的图象照片库管理程序。
        LinPHA在通过COOKIE进行验证时存在问题,远程攻击者可以利用这个漏洞未授权访问系统。
        问题存在于session.php文件中,由于对linpha_userid和linpha_password COOKIE信息验证处理不正确,攻击者可以修改会话的COOKIE信息,不需要密码访问LinPHA系统。
        

- 公告与补丁

        厂商补丁:
        LinPHA
        ------
        linpha的CVS版本已经修正此问题:
        
        http://linpha.sourceforge.net/nuke/index.php

        --- linpha/linpha/include/session.php 2004/07/06 07:20:34 1.12
        +++ linpha/linpha/include/session.php 2004/07/19 06:44:16 1.13
        @@ -25,8 +25,8 @@
        isset($_COOKIE["linpha_password"])&&$_COOKIE["linpha_password"]!="")
        {
        $query_username = $GLOBALS['db']->Execute("SELECT nickname, level, groups FROM
        ".PREFIX."users ".
        - "WHERE ID = '".$_COOKIE["linpha_userid"]."' AND ".
        - "password = '".$_COOKIE["linpha_password"]."'");
        + "WHERE ID = '".addslashes($_COOKIE["linpha_userid"])."' ".
        + "AND password = '".addslashes($_COOKIE["linpha_password"])."'");
        if($row = $query_username->FetchRow())
        {
        $_SESSION["REMOTE_ADDR"] = @$_SERVER["REMOTE_ADDR"];

- 漏洞信息

8272
LinPHA Cookie Modification Admin Authentication Bypass
Remote / Network Access Authentication Management, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

LinPHA contains a flaw that will allow an attacker to bypass authentication. The problem is due to a input validation error within the 'session.php' script and will allow an attacker to inject specially crafted session cookies prior to loading admin.php allowing the attacker to bypass authentication.

- 时间线

2004-07-29 Unknow
2004-07-29 Unknow

- 解决方案

Upgrade to version 1.13 of session.php or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds. The fix is available via CVS from the vendor.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站