CVE-2004-2023
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:05:04
NMCO    

[原文]SQL injection vulnerability in login.php in Zen Cart 1.1.2d, 1.1.4 before patch 1, and possibly other versions allows remote attackers to execute arbitrary SQL via the (1) admin_name or (2) admin_pass parameters.


[CNNVD]Zen Cart Login.PHP SQL注入漏洞(CNNVD-200412-215)

        Zen Cart 1.1.2d版本,补丁1之前的1.1.4版本及其他可能的版本存在SQL注入漏洞。远程攻击者可以借助(1)admin_name或(2)admin_pass参数执行任意SQL。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:zen_cart:zen_cart:1.1.4
cpe:/a:zen_cart:zen_cart:1.1.2d

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2023
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2023
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-215
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108489697219781&w=2
(UNKNOWN)  BUGTRAQ  20040518 Zen Cart login.php SQL Injection Vulnerability
http://securitytracker.com/id?1010172
(UNKNOWN)  SECTRACK  1010172
http://www.packetstormsecurity.org/0405-advisories/zencart112d.txt
(UNKNOWN)  MISC  http://www.packetstormsecurity.org/0405-advisories/zencart112d.txt
http://www.securityfocus.com/archive/1/archive/1/434237/30/4950/threaded
(UNKNOWN)  BUGTRAQ  20060517 Re: Zen Cart login.php SQL Injection Vulnerability
http://www.securityfocus.com/bid/10378
(UNKNOWN)  BID  10378
http://www.zen-cart.com/modules/ipb/index.php?showtopic=4835
(VENDOR_ADVISORY)  CONFIRM  http://www.zen-cart.com/modules/ipb/index.php?showtopic=4835
http://www.zen-cart.com/modules/mydownloads/viewcat.php?cid=31&orderby=dateD
(PATCH)  CONFIRM  http://www.zen-cart.com/modules/mydownloads/viewcat.php?cid=31&orderby=dateD
http://xforce.iss.net/xforce/xfdb/16176
(PATCH)  XF  zencart-login-sql-injection(16176)

- 漏洞信息

Zen Cart Login.PHP SQL注入漏洞
高危 SQL注入
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Zen Cart 1.1.2d版本,补丁1之前的1.1.4版本及其他可能的版本存在SQL注入漏洞。远程攻击者可以借助(1)admin_name或(2)admin_pass参数执行任意SQL。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息

6298
Zen Cart login.php Multiple Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

Zen Cart contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the '/admin/login.php' file does not properly validate user-supplied input in the "admin_name" and "admin_pass" variables and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-05-17 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.1.3 or higher and apply the appropriate patch, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站