CVE-2004-2016
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:04:54
NMCO    

[原文]Stack-based buffer overflow in the HTTP server in NetChat 7.3 and earlier allows remote attackers to execute arbitrary code via a long GET request.


[CNNVD]NetChat Web Server远程缓冲区溢出漏洞(CNNVD-200412-220)

        
        NetChat Web Server是一款可基于WEB聊天的服务程序。
        NetChat Web服务程序对用户提供的输入缺少充分边界缓冲区检查,远程攻击者可以利用这个漏洞对WEB服务程序进行缓冲区溢出攻击。
        当传递用户提供的外部输入到进程内存时,没有对数据大小长度进行正确的检查,提交超多数据可覆盖进程内存,可能导致以进程权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:netchat:subnet_chat_application:7.1
cpe:/a:netchat:subnet_chat_application:7.2
cpe:/a:netchat:subnet_chat_application:7.0
cpe:/a:netchat:subnet_chat_application:7.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2016
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2016
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-220
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108481422130354&w=2
(UNKNOWN)  BUGTRAQ  20040517 NetChat HTTP Server Stack Overflow
http://www.securityfocus.com/bid/10353
(PATCH)  BID  10353
http://xforce.iss.net/xforce/xfdb/16165
(UNKNOWN)  XF  netchat-sprintf-bo(16165)

- 漏洞信息

NetChat Web Server远程缓冲区溢出漏洞
高危 边界条件错误
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        NetChat Web Server是一款可基于WEB聊天的服务程序。
        NetChat Web服务程序对用户提供的输入缺少充分边界缓冲区检查,远程攻击者可以利用这个漏洞对WEB服务程序进行缓冲区溢出攻击。
        当传递用户提供的外部输入到进程内存时,没有对数据大小长度进行正确的检查,提交超多数据可覆盖进程内存,可能导致以进程权限在系统上执行任意指令。
        

- 公告与补丁

        厂商补丁:
        NetChat
        -------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        NetChat Upgrade NetChat.zip
        
        http://www.geocities.com/SiliconValley/Platform/1297/misc/NetChat.zip

- 漏洞信息

6297
NetChat GET Request Handling Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

A remote overflow exists in NetChat. The issue is triggered due to improper bounds checking of the HTTP service when processing GET requests, resulting in a buffer overflow. With a specially crafted request, an remote attacker can cause arbitrary code exection resulting in a loss of integrity.

- 时间线

2004-05-16 2004-05-12
Unknow Unknow

- 解决方案

Upgrade to version 7.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站