CVE-2004-2009
CVSS5.0
发布时间 :2004-05-08 00:00:00
修订时间 :2016-10-17 23:04:45
NMCO    

[原文]NukeJokes 1.7 and 2 Beta allows remote attackers to obtain the full path of the server via (1) a direct call to mainfunctions.php, (2) an invalid jokeid parameter in a JokeView function or (3) an invalid cat parameter in a CatView function, which reveals the path in a PHP error message.


[CNNVD]NukeJokes漏洞(CNNVD-200405-051)

        NukeJokes 1.7 and 2 Beta版本存在漏洞。远程攻击者借助(1)对mainfunctions.php直接调用,(2)JokeView函数中的无效jokeid参数或者(3)CatView函数中的无效cat参数得到服务器完全的路径,该漏洞揭露PHP错误信息的路径。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2009
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2009
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200405-051
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108404714232579&w=2
(UNKNOWN)  BUGTRAQ  20040508 [waraxe-2004-SA#028 - Multiple vulnerabilities in NukeJokes module for PhpNuke]
http://xforce.iss.net/xforce/xfdb/16094
(VENDOR_ADVISORY)  XF  nukejokes-multiple-path-disclosure(16094)

- 漏洞信息

NukeJokes漏洞
中危 未知
2004-05-08 00:00:00 2005-10-20 00:00:00
远程  
        NukeJokes 1.7 and 2 Beta版本存在漏洞。远程攻击者借助(1)对mainfunctions.php直接调用,(2)JokeView函数中的无效jokeid参数或者(3)CatView函数中的无效cat参数得到服务器完全的路径,该漏洞揭露PHP错误信息的路径。

- 公告与补丁

        

- 漏洞信息

6011
PHP-Nuke NukeJokes Module Path Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality
Exploit Public

- 漏洞描述

NukeJokes contains a flaw that may lead to an unauthorized information disclosure. This flaw exists because the application does not validate the "jokeid" or "cat" variables upon submission to the NukeJokes module. This could allow a remote attacker to create specially crafted GET requests, which will disclose the installation path resulting in a loss of confidentiality.

- 时间线

2004-05-08 Unknow
2004-05-08 Unknow

- 解决方案

Upgrade to version 2.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站