发布时间 :2004-05-08 00:00:00
修订时间 :2016-10-17 23:04:42

[原文]Cross-site scripting (XSS) vulnerability in modules.php in NukeJokes 1.7 and 2 Beta allows remote attackers to inject arbitrary HTML or web script via the (1) cat parameter in a CatView function or (2) jokeid parameter in a JokeView function.

[CNNVD]PHP-Nuke Adam Webb NukeJokes模块多个输入验证漏洞(CNNVD-200405-052)


- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20040508 [waraxe-2004-SA#028 - Multiple vulnerabilities in NukeJokes module for PhpNuke]
(VENDOR_ADVISORY)  XF  nukejokes-modules-xss(16096)

- 漏洞信息

PHP-Nuke Adam Webb NukeJokes模块多个输入验证漏洞
中危 输入验证
2004-05-08 00:00:00 2005-10-20 00:00:00

- 公告与补丁

        Adam Webb

- 漏洞信息 (24099)

Adam Webb NukeJokes 1.7/2.0 Module Multiple Parameter XSS (EDBID:24099)
php webapps
2004-05-08 Verified
0 Janek Vind
N/A [点击下载]

It has been reported that the NukeJokes module is affected by multiple input validation vulnerabilities. These issues are due to a failure of the application to properly sanitize user supplied user input.

Multiple SQL injection issues exists due to a failure of the application to do any sanitization on user input prior to using the offending input in an SQL query.

These SQL issues may allow a remote attacker to manipulate query logic, potentially leading to unauthorized access to sensitive information such as the administrator password hash or corruption of database data.

Multiple cross-site scripting vulnerabilities have been reported to exist due to a failure of the application to properly sanitize user-supplier input before its inclusion in dynamic web content. 

These cross-site scripting issues could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were followed, the hostile code may be rendered in the web browser of the victim user.[xss code here][xss code here]		

- 漏洞信息

PHP-Nuke NukeJokes Module Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

NukeJokes contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "cat" or "jokeid" variable upon submission to the NukeJokes module. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-05-08 Unknow
2004-05-08 Unknow

- 解决方案

Upgrade to version 2.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者