CVE-2004-2001
CVSS4.6
发布时间 :2004-05-05 00:00:00
修订时间 :2008-09-05 16:42:55
NMCOS    

[原文]ifconfig "-arp" in SGI IRIX 6.5 through 6.5.22m does not properly disable ARP requests from being sent or received.


[CNNVD]SGI IRIX ifconfig命令实现漏洞(CNNVD-200405-045)

        
        IRIX是一款由SGI公司开发和维护的商业性质UNIX操作系统。
        SGI IRIX的ifconfig %interface% -arp命令在执行时存在问题,可导致忽略安全问题。
        SGI IRIX ifconfig %interface% -arp命令可针对特定接口关闭ARP通信处理,但是在某些情况下,会使命令失败,造成网络管理员忽略了安全威胁。
        

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sgi:irix:6.5.18fSGI IRIX 6.5.18f
cpe:/o:sgi:irix:6.5.6SGI IRIX 6.5.6
cpe:/o:sgi:irix:6.5.15SGI IRIX 6.5.15
cpe:/o:sgi:irix:6.5.13SGI IRIX 6.5.13
cpe:/o:sgi:irix:6.5.18mSGI IRIX 6.5.18m
cpe:/o:sgi:irix:6.5.14SGI IRIX 6.5.14
cpe:/o:sgi:irix:6.5.19fSGI IRIX 6.5.19f
cpe:/o:sgi:irix:6.5.17mSGI IRIX 6.5.17m
cpe:/o:sgi:irix:6.5.11SGI IRIX 6.5.11
cpe:/o:sgi:irix:6.5.19mSGI IRIX 6.5.19m
cpe:/o:sgi:irix:6.5.22mSGI IRIX 6.5.22m
cpe:/o:sgi:irix:6.5.3SGI IRIX 6.5.3
cpe:/o:sgi:irix:6.5.16SGI IRIX 6.5.16
cpe:/o:sgi:irix:6.5.9SGI IRIX 6.5.9
cpe:/o:sgi:irix:6.5.21fSGI IRIX 6.5.21f
cpe:/o:sgi:irix:6.5.12SGI IRIX 6.5.12
cpe:/o:sgi:irix:6.5.8SGI IRIX 6.5.8
cpe:/o:sgi:irix:6.5.20mSGI IRIX 6.5.20m
cpe:/o:sgi:irix:6.5SGI IRIX 6.5
cpe:/o:sgi:irix:6.5.7SGI IRIX 6.5.7
cpe:/o:sgi:irix:6.5.5SGI IRIX 6.5.5
cpe:/o:sgi:irix:6.5.4SGI IRIX 6.5.4
cpe:/o:sgi:irix:6.5.10SGI IRIX 6.5.10
cpe:/o:sgi:irix:6.5.1SGI IRIX 6.5.1
cpe:/o:sgi:irix:6.5.2SGI IRIX 6.5.2
cpe:/o:sgi:irix:6.5.21mSGI IRIX 6.5.21m
cpe:/o:sgi:irix:6.5.20fSGI IRIX 6.5.20f
cpe:/o:sgi:irix:6.5.17fSGI IRIX 6.5.17f

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2001
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2001
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200405-045
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/10289
(VENDOR_ADVISORY)  BID  10289
ftp://patches.sgi.com/support/free/security/advisories/20040502-01-P.asc
(VENDOR_ADVISORY)  SGI  20040502-01-P

- 漏洞信息

SGI IRIX ifconfig命令实现漏洞
中危 设计错误
2004-05-05 00:00:00 2005-10-20 00:00:00
本地  
        
        IRIX是一款由SGI公司开发和维护的商业性质UNIX操作系统。
        SGI IRIX的ifconfig %interface% -arp命令在执行时存在问题,可导致忽略安全问题。
        SGI IRIX ifconfig %interface% -arp命令可针对特定接口关闭ARP通信处理,但是在某些情况下,会使命令失败,造成网络管理员忽略了安全威胁。
        

- 公告与补丁

        厂商补丁:
        SGI
        ---
        SGI已经为此发布了一个安全公告(20050502-01-P)以及相应补丁:
        20050502-01-P:IRIX Networking Security Updates
        链接:ftp://patches.sgi.com/support/free/security/advisories/20050502-01-P
        补丁下载:
        SGI IRIX 6.5.18 m:
        SGI Patch 5454
        ftp://patches.sgi.com/
        SGI IRIX 6.5.18 f:
        SGI Patch 5461
        ftp://patches.sgi.com/
        SGI IRIX 6.5.19 m:
        SGI Patch 5437
        ftp://patches.sgi.com/
        SGI IRIX 6.5.19 f:
        SGI Patch 5466
        ftp://patches.sgi.com/
        SGI IRIX 6.5.20 m:
        SGI Patch 5510
        ftp://patches.sgi.com/
        SGI Patch 5513
        ftp://patches.sgi.com/
        SGI IRIX 6.5.20 f:
        SGI Patch 5513
        ftp://patches.sgi.com/
        SGI Patch 5440
        ftp://patches.sgi.com/
        SGI IRIX 6.5.21 m:
        SGI Patch 5513
        ftp://patches.sgi.com/
        SGI Patch 5415
        ftp://patches.sgi.com/
        SGI IRIX 6.5.21 f:
        SGI Patch 5513
        ftp://patches.sgi.com/
        SGI Patch 5416
        ftp://patches.sgi.com/
        SGI IRIX 6.5.22 m:
        SGI Patch 5469
        ftp://patches.sgi.com/
        SGI Patch 5509
        ftp://patches.sgi.com/

- 漏洞信息

6049
IRIX ifconfig -arp Option Failure
Local Access Required Denial of Service
Loss of Availability
Exploit Unknown

- 漏洞描述

ifconfig in SGI IRIX contains a flaw that may allow a local denial of service. The issue is triggered due to the -"arp" argument within ifconfig which does not disable arp requests being sent or received, and will result in loss of availability for the machine. No further details have been provided.

- 时间线

2004-05-02 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, SGI has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SGI IRIX IFConfig -ARP Failure To Disable ARP Functionality Vulnerability
Design Error 10289
No Yes
2004-05-05 12:00:00 2009-07-12 04:07:00
The vendor announced this vulnerability.

- 受影响的程序版本

SGI IRIX 6.5.22 m
SGI IRIX 6.5.21 m
SGI IRIX 6.5.21 f
SGI IRIX 6.5.20 m
SGI IRIX 6.5.20 f
SGI IRIX 6.5.19 m
SGI IRIX 6.5.19 f
SGI IRIX 6.5.18 m
SGI IRIX 6.5.18 f
SGI IRIX 6.5.17 m
SGI IRIX 6.5.17 f
SGI IRIX 6.5.16
SGI IRIX 6.5.15
SGI IRIX 6.5.14
SGI IRIX 6.5.13
SGI IRIX 6.5.12
SGI IRIX 6.5.11
SGI IRIX 6.5.10
SGI IRIX 6.5.9
SGI IRIX 6.5.8
SGI IRIX 6.5.7
SGI IRIX 6.5.6
SGI IRIX 6.5.5
SGI IRIX 6.5.4
SGI IRIX 6.5.3
SGI IRIX 6.5.2
SGI IRIX 6.5.1
SGI IRIX 6.5
SGI IRIX 4.0.3

- 漏洞讨论

Expected functionality of ifconfig %interface% -arp is that ARP communications are disabled for the specified interface.

SGI IRIX ifconfig %interface% -arp fails to disable ARP handling on the specified interface. This may lead a network administrator into a false sense of security.

- 漏洞利用

There is no exploit required.

- 解决方案

SGI has released an advisory (20050502-01-P) and patches to address this issue in SGI IRIX. Customers are advised to see the referenced advisory for further details regarding obtaining and applying appropriate patches.


SGI IRIX 6.5.18 m

SGI IRIX 6.5.18 f

SGI IRIX 6.5.19 m

SGI IRIX 6.5.19 f

SGI IRIX 6.5.20 m

SGI IRIX 6.5.20 f

SGI IRIX 6.5.21 m

SGI IRIX 6.5.21 f

SGI IRIX 6.5.22 m

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站