CVE-2004-2000
CVSS7.5
发布时间 :2004-05-05 00:00:00
修订时间 :2016-10-17 23:04:37
NMCO    

[原文]SQL injection vulnerability in the Downloads module in Php-Nuke 6.x through 7.2 allows remote attackers to execute arbitrary SQL via the (1) orderby or (2) sid parameters to modules.php.


[CNNVD]PHP-Nuke modules.php模块SQL注入漏洞(CNNVD-200405-040)

        
        PHP-Nuke是一个广为流行的网站创建和管理工具,它可以使用很多数据库软件作为后端,比如MySQL、PostgreSQL、mSQL、Interbase、Sybase等。
        PHP-Nuke包含的'modules.php'模块对用户提交的输入缺少充分过滤,远程攻击者可以利用这个漏洞获得用户的敏感信息。
        'modules.php'模块对用户提交给"orderby"和"sid"变量缺少过滤,提交包含恶意SQL命令作为此变量数据,可更改原有SQL逻辑,获得数据库中敏感信息或更改数据库信息。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2000
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2000
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200405-040
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108378804809891&w=2
(UNKNOWN)  BUGTRAQ  20040505 [waraxe-2004-SA#027 - Once again - critical vulnerabilities in PhpNuke 6.x - 7.2]
http://www.securityfocus.com/archive/1/archive/1/488452/100/0/threaded
(UNKNOWN)  BUGTRAQ  20080221 PHP-Nuke Module Downloads SQL Injection(sid)
http://www.securityfocus.com/bid/10282
(VENDOR_ADVISORY)  BID  10282
http://www.securityfocus.com/bid/27932
(UNKNOWN)  BID  27932
http://www.waraxe.us/index.php?modname=sa&id=27
(UNKNOWN)  MISC  http://www.waraxe.us/index.php?modname=sa&id=27
http://xforce.iss.net/xforce/xfdb/16074
(VENDOR_ADVISORY)  XF  phpnuke-orderby-sid-sql-injection(16074)

- 漏洞信息

PHP-Nuke modules.php模块SQL注入漏洞
高危 输入验证
2004-05-05 00:00:00 2009-09-19 00:00:00
远程  
        
        PHP-Nuke是一个广为流行的网站创建和管理工具,它可以使用很多数据库软件作为后端,比如MySQL、PostgreSQL、mSQL、Interbase、Sybase等。
        PHP-Nuke包含的'modules.php'模块对用户提交的输入缺少充分过滤,远程攻击者可以利用这个漏洞获得用户的敏感信息。
        'modules.php'模块对用户提交给"orderby"和"sid"变量缺少过滤,提交包含恶意SQL命令作为此变量数据,可更改原有SQL逻辑,获得数据库中敏感信息或更改数据库信息。
        

- 公告与补丁

        厂商补丁:
        Francisco Burzi
        ---------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.phpnuke.org

- 漏洞信息

5915
PHP-Nuke Downloads Module Multiple Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

PHP-Nuke contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the "orderby" and "sid" variables in the module.php module are not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-05-05 Unknow
2004-05-05 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站