发布时间 :2004-04-30 00:00:00
修订时间 :2016-10-17 23:04:08

[原文]Cross-site scripting (XSS) vulnerability in help.php in Moodle before 1.3 allows remote attackers to inject arbitrary HTML and web script via the text parameter.

[CNNVD]Moodle Cross Site脚本漏洞(CNNVD-200404-107)

        Moodle 1.3之前版本的help.php存在跨站脚本漏洞。远程攻击者借助text参数注入任意的HTML和web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:moodle:moodle:1.2Moodle 1.2
cpe:/a:moodle:moodle:1.2.1Moodle 1.2.1
cpe:/a:moodle:moodle:1.1.1Moodle 1.1.1

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20040430 Cross Site Scripting in Moodle < 1.3
(VENDOR_ADVISORY)  XF  moodle-help-xss(16023)

- 漏洞信息

Moodle Cross Site脚本漏洞
中危 跨站脚本
2004-04-30 00:00:00 2005-10-20 00:00:00
        Moodle 1.3之前版本的help.php存在跨站脚本漏洞。远程攻击者借助text参数注入任意的HTML和web脚本。

- 公告与补丁

        The vendor has released an upgrade dealing with this issue.
        Moodle moodle 1.1.1
        Moodle moodle 1.2
        Moodle moodle 1.2.1

- 漏洞信息 (24071)

Moodle 1.1/1.2 Cross Site Scripting Vulnerability (EDBID:24071)
php webapps
2004-04-30 Verified
0 Bartek Nowotarski
N/A [点击下载]

It has been reported that Moodle is susceptible to a cross-site scripting vulnerability in the 'help.php' script. This issue is due to a failure of the application to properly sanitize user-supplied input prior to including it in dynamic web content.

This issue may allow for theft of cookie-based authentication credentials. Other attacks are also possible.{XSS}		

- 漏洞信息

Moodle help.php text Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Moodle contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'text' variables upon submission to the help.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-04-30 2004-04-30
2004-04-30 Unknow

- 解决方案

Upgrade to version 1.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者