CVE-2004-1975
CVSS4.3
发布时间 :2004-04-27 00:00:00
修订时间 :2016-10-17 23:04:05
NMCS    

[原文]Cross-site scripting (XSS) vulnerability in the category module in pafiledb.php for paFileDB 3.1 allows remote attackers to inject arbitrary web script or HTML via the id parameter, a vulnerability that is closely related to CVE-2004-1551.


[CNNVD]PAFileDB ID变量跨站脚本漏洞(CNNVD-200404-096)

        paFileDB 3.1版本文件pafiledb.php中的分类模块存在跨站脚本(XSS)漏洞。远程攻击者可以通过id参数注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:php_arena:pafiledb:3.0
cpe:/a:php_arena:pafiledb:3.1
cpe:/a:php_arena:pafiledb:3.0_beta_3.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1975
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1975
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200404-096
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108311096022485&w=2
(UNKNOWN)  BUGTRAQ  20040427 Multiple vulnerabilities paFileDB
http://marc.info/?l=bugtraq&m=109613031414184&w=2
(UNKNOWN)  BUGTRAQ  20040925 New XSS vulnerabilities in paFileDB 3.1 final
http://www.securityfocus.com/bid/10229
(VENDOR_ADVISORY)  BID  10229
http://xforce.iss.net/xforce/xfdb/15992
(VENDOR_ADVISORY)  XF  pafiledb-pafiledbphp-xss(15992)

- 漏洞信息

PAFileDB ID变量跨站脚本漏洞
中危 跨站脚本
2004-04-27 00:00:00 2005-10-25 00:00:00
远程  
        paFileDB 3.1版本文件pafiledb.php中的分类模块存在跨站脚本(XSS)漏洞。远程攻击者可以通过id参数注入任意web脚本或HTML。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.commailto:vuldb@securityfocus.com.

- 漏洞信息

PAFileDB ID Variable Cross-Site Scripting Vulnerability
Input Validation Error 10229
Yes No
2004-04-28 12:00:00 2006-11-08 09:22:00
Discovered by DarkBicho <darkbicho@peru.com>.

- 受影响的程序版本

PHP Arena paFileDB 3.1
PHP Arena paFileDB 3.0 Beta 3.1
PHP Arena paFileDB 3.0
PHP Arena paFileDB 2.1.1
PHP Arena paFileDB 1.1.3

- 漏洞讨论

A cross-site scripting vulnerability has been reported in paFileDB.

An attacker may construct a malicious link to this web application containing embedded arbitrary HTML and script code. If a vistim user follows the link, the attacker may be able to steal cookie-based authentication credentials or launch other attacks.

This issue is reported to reside in version 3.x; other versions may be affected as well.

- 漏洞利用

No exploit code is required.

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.commailto:vuldb@securityfocus.com.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站