CVE-2004-1957
CVSS2.6
发布时间 :2004-04-21 00:00:00
修订时间 :2016-10-17 23:03:45
NMCOE    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in PostNuke 0.726 allows remote attackers to inject arbitrary web script or HTML via the (1) lid and query parameters to the Downloads module, (2) query parameter to the Web_links module, or (3) hlpfile parameter to openwindow.php.


[CNNVD]PostNuke Pheonix多个跨站脚本及路径泄露漏洞(CNNVD-200404-077)

        
        PHP-Nuke是一个广为流行的网站创建和管理工具,它可以使用很多数据库软件作为后端,比如MySQL、PostgreSQL、mSQL、Interbase、Sybase等。
        PHP-Nuke包含的Pheonix模块存在多个输入过滤问题,远程攻击者可以利用这些漏洞获得敏感信息。
        直接请求"/includes/blocks/"和"pnadodb"目录下的脚本,可泄露路径敏感信息。
        另外openwindow.php脚本中的Downloads和Web_links模块存在多个跨站脚本问题,可导致攻击者构建恶意链接,诱使用户处理,可获得目标用户敏感信息。
        

- CVSS (基础分值)

CVSS分值: 2.6 [轻微(LOW)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1957
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1957
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200404-077
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108258902000472&w=2
(UNKNOWN)  BUGTRAQ  20040421 [waraxe-2004-SA#022 - Multiple vulnerabilities in PostNuke 0.726 Phoenix - part 2]
http://www.securityfocus.com/bid/10191
(VENDOR_ADVISORY)  BID  10191
http://www.waraxe.us/index.php?modname=sa&id=22
(VENDOR_ADVISORY)  MISC  http://www.waraxe.us/index.php?modname=sa&id=22
http://xforce.iss.net/xforce/xfdb/15934
(VENDOR_ADVISORY)  XF  postnuke-openwindow-xss(15934)

- 漏洞信息

PostNuke Pheonix多个跨站脚本及路径泄露漏洞
低危 输入验证
2004-04-21 00:00:00 2006-04-07 00:00:00
远程  
        
        PHP-Nuke是一个广为流行的网站创建和管理工具,它可以使用很多数据库软件作为后端,比如MySQL、PostgreSQL、mSQL、Interbase、Sybase等。
        PHP-Nuke包含的Pheonix模块存在多个输入过滤问题,远程攻击者可以利用这些漏洞获得敏感信息。
        直接请求"/includes/blocks/"和"pnadodb"目录下的脚本,可泄露路径敏感信息。
        另外openwindow.php脚本中的Downloads和Web_links模块存在多个跨站脚本问题,可导致攻击者构建恶意链接,诱使用户处理,可获得目标用户敏感信息。
        

- 公告与补丁

        厂商补丁:
        PostNuke
        --------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.postnuke.com/

- 漏洞信息 (22997)

PostNuke 0.6/0.7 Downloads Module TTitle Cross-site Scripting Vulnerability (EDBID:22997)
php webapps
2003-08-08 Verified
0 Lorenzo Hernandez Garcia-Hierro
N/A [点击下载]
source: http://www.securityfocus.com/bid/8374/info

It has been reported that a cross site scripting vulnerability exists in the Downlaods and Web_Links modules of PostNuke. It is possible that an attacker may construct a link containing malicious script code that could be executed in a browser of a user who visits the link.

Exploitation could allow theft of authentication cookies.

http://www.example.com/[PATH]/modules.php?
op=modload&name=Downloads&file=index&req=viewdownloaddetails&lid=[ID]
&ttitle=[Yeye XSS ;-)]"%3e[XSS ATTACK]
		

- 漏洞信息 (24037)

PostNuke Phoenix 0.726 openwindow.php hlpfile Parameter XSS (EDBID:24037)
php webapps
2004-04-21 Verified
0 Janek Vind
N/A [点击下载]
source: http://www.securityfocus.com/bid/10191/info

Multiple vulnerabilities were reported to exist in PostNuke Phoenix. The following specific vulnerabilities were reported: 

- Multiple path disclosure vulnerabilities that occur when a user directly requests scripts in the "/includes/blocks/" and "pnadodb" directories. This issue also affects scripts that are associated in multiple modules.

- Multiple cross-site scripting vulnerabilities were reported in the Downloads and Web_Links modules as well as the openwindow.php script. These issues may permit remote attackers to cause hostile HTML and script code to be interpreted by a victim user's browser.

http://www.example.com/postnuke0726/javascript/openwindow.php?hlpfile=x<html><body>[xss code here]
http://www.example.com/postnuke0726/javascript/openwindow.php?hlpfile=x<html><body%20onload=alert(document.cookie);>		

- 漏洞信息

5628
PostNuke Downloads Module Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

PostNuke contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate ttitle variable upon submission to the Downloads Module script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2003-08-08 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.726-1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站