CVE-2004-1956
CVSS5.0
发布时间 :2004-04-21 00:00:00
修订时间 :2016-10-17 23:03:44
NMCO    

[原文]PostNuke 0.7.2.6 allows remote attackers to gain information via a direct HTTP request to files in the (1) includes/blocks directory, (2) pnadodb directory, (3) NS-NewUser module, (4) NS-Your_Account, (5) NS-LostPassword module, or (6) NS-User module which reveals the path to the web server in a PHP error message.


[CNNVD]PostNuke Pheonix多个跨站脚本及路径泄露漏洞(CNNVD-200404-078)

        
        PHP-Nuke是一个广为流行的网站创建和管理工具,它可以使用很多数据库软件作为后端,比如MySQL、PostgreSQL、mSQL、Interbase、Sybase等。
        PHP-Nuke包含的Pheonix模块存在多个输入过滤问题,远程攻击者可以利用这些漏洞获得敏感信息。
        直接请求"/includes/blocks/"和"pnadodb"目录下的脚本,可泄露路径敏感信息。
        另外openwindow.php脚本中的Downloads和Web_links模块存在多个跨站脚本问题,可导致攻击者构建恶意链接,诱使用户处理,可获得目标用户敏感信息。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1956
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1956
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200404-078
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108258902000472&w=2
(UNKNOWN)  BUGTRAQ  20040421 [waraxe-2004-SA#022 - Multiple vulnerabilities in PostNuke 0.726 Phoenix - part 2]
http://www.securityfocus.com/bid/10191
(VENDOR_ADVISORY)  BID  10191
http://www.waraxe.us/index.php?modname=sa&id=22
(VENDOR_ADVISORY)  MISC  http://www.waraxe.us/index.php?modname=sa&id=22
http://xforce.iss.net/xforce/xfdb/15933
(VENDOR_ADVISORY)  XF  postnuke-scripts-modules-path-disclosure(15933)

- 漏洞信息

PostNuke Pheonix多个跨站脚本及路径泄露漏洞
中危 输入验证
2004-04-21 00:00:00 2006-04-07 00:00:00
远程  
        
        PHP-Nuke是一个广为流行的网站创建和管理工具,它可以使用很多数据库软件作为后端,比如MySQL、PostgreSQL、mSQL、Interbase、Sybase等。
        PHP-Nuke包含的Pheonix模块存在多个输入过滤问题,远程攻击者可以利用这些漏洞获得敏感信息。
        直接请求"/includes/blocks/"和"pnadodb"目录下的脚本,可泄露路径敏感信息。
        另外openwindow.php脚本中的Downloads和Web_links模块存在多个跨站脚本问题,可导致攻击者构建恶意链接,诱使用户处理,可获得目标用户敏感信息。
        

- 公告与补丁

        厂商补丁:
        PostNuke
        --------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.postnuke.com/

- 漏洞信息

60304
PostNuke Multiple Directory Direct Request Path Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality
Exploit Public

- 漏洞描述

- 时间线

2004-04-21 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站