CVE-2004-1954
CVSS4.3
发布时间 :2004-04-21 00:00:00
修订时间 :2016-10-17 23:03:41
NMCOE    

[原文]Cross-site scripting (XSS) vulnerability in modules.php in phProfession 2.5 allows remote attackers to inject arbitrary web script or HTML via the jcode parameter.


[CNNVD]PHProfession多个漏洞(CNNVD-200404-079)

        phProfession 2.5版本中的modules.php存在跨站脚本(XSS)漏洞。远程攻击者可以通过jcode参数注入任意的web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1954
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1954
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200404-079
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108258931430060&w=2
(UNKNOWN)  BUGTRAQ  20040421 [waraxe-2004-SA#021 - Multiple vulnerabilities in phprofession 2.5 module for PostNuke]
http://www.securityfocus.com/bid/10190
(VENDOR_ADVISORY)  BID  10190
http://www.waraxe.us/index.php?modname=sa&id=21
(VENDOR_ADVISORY)  MISC  http://www.waraxe.us/index.php?modname=sa&id=21
http://xforce.iss.net/xforce/xfdb/15931
(UNKNOWN)  XF  phprofession-jcode-xss(15931)

- 漏洞信息

PHProfession多个漏洞
中危 跨站脚本
2004-04-21 00:00:00 2005-10-20 00:00:00
远程  
        phProfession 2.5版本中的modules.php存在跨站脚本(XSS)漏洞。远程攻击者可以通过jcode参数注入任意的web脚本或HTML。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息 (24036)

phProfession 2.5 modules.php jcode Parameter XSS (EDBID:24036)
php webapps
2004-04-23 Verified
0 Janek Vind
N/A [点击下载]
source: http://www.securityfocus.com/bid/10190/info
  
Multiple vulnerabilities were reported to exist in phProfession, which is a third-party module for PostNuke. Path disclosure, cross-site scripting and SQL injection vulnerabilities were reported.
  
Exploitation of these issues may reveal sensitive information, allow for account hijacking, content manipulation and attacks against the underlying database.
  
These issues were reported to exist in phProfession 2.5. Other versions may also be affected.

http://www.example.com/postnuke0726/modules.php?op=modload&name=phprofession&file=upload&jcode=[xss code here]		

- 漏洞信息

5624
PHP-Nuke phProfession modules.php jcode Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phProfession contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "jcode" variable upon submission to the "modules.php" script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-04-21 Unknow
2004-04-21 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站