CVE-2004-1949
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:03:36
NMCO    

[原文]SQL injection vulnerability in PostNuke 7.2.6 and earlier allows remote attackers to execute arbitrary SQL via (1) the sif parameter to index.php in the Comments module or (2) timezoneoffset parameter to changeinfo.php in the Your_Account module.


[CNNVD]PostNuke Phoenix多个模块SQL注入漏洞(CNNVD-200412-253)

        PostNuke 7.2.6版本及之前版本中存在SQL注入漏洞。远程攻击者可以借助(1)Comments模块中index.php的sif参数或者(2)Your_Account模块中changeinfo.php的timezoneoffset参数执行任意SQL。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1949
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1949
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-253
(官方数据源) CNNVD

- 其它链接及资源

http://lists.grok.org.uk/pipermail/full-disclosure/2004-April/020154.html
(UNKNOWN)  FULLDISC  20040414 [SCAN Associates Sdn Bhd Security Advisory] Postnuke v 0.726 and below SQL injection
http://marc.info/?l=bugtraq&m=108256503718978&w=2
(UNKNOWN)  BUGTRAQ  20040420 [PNSA 2004-2] PostNuke Security Advisory PNSA 2004-2
http://news.postnuke.com/Article2580.html
(VENDOR_ADVISORY)  CONFIRM  http://news.postnuke.com/Article2580.html
http://securitytracker.com/id?1009801
(UNKNOWN)  SECTRACK  1009801
http://www.securityfocus.com/bid/10146
(PATCH)  BID  10146
http://xforce.iss.net/xforce/xfdb/15869
(UNKNOWN)  XF  postnuke-indexphp-sql-injection(15869)
http://xforce.iss.net/xforce/xfdb/15875
(UNKNOWN)  XF  postnuke-changeinfo-sql-injection(15875)

- 漏洞信息

PostNuke Phoenix多个模块SQL注入漏洞
高危 SQL注入
2004-12-31 00:00:00 2006-04-07 00:00:00
远程  
        PostNuke 7.2.6版本及之前版本中存在SQL注入漏洞。远程攻击者可以借助(1)Comments模块中index.php的sif参数或者(2)Your_Account模块中changeinfo.php的timezoneoffset参数执行任意SQL。

- 公告与补丁

        The vendor has released advisory PNSA 2004-2 as well as a patch and an upgrade dealing with this issue.
        PostNuke Development Team PostNuke Phoenix 0.726
        

- 漏洞信息

5368
PostNuke index.php sif Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

PostNuke contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the "sif" variable in the "modules/NS-Comments/index.php" module is not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-04-14 Unknow
2004-04-14 Unknow

- 解决方案

PostNuke has released a patch to address this vulnerability. It is also possible to correct the flaw by implementing the following workaround: Modify the source code such that the $sid and $pid variables in modules/NS-Comments/index.php line 1142 are properly verified: VALUES ($nextid, '".pnVarPrepForStore($pid)."', '".pnVarPrepForStore($sid)."', now(), '".pnVarPrepForStore($uname)."', '".pnVarPrepForStore($email)."', '".pnVarPrepForStore($url)."', '".pnVarPrepForStore($ip)."', '".pnVarPrepForStore($subject)."', '".pnVarPrepForStore($comment)."', '".pnVarPrepForStore($score)."', 0)");

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站