CVE-2004-1938
CVSS7.5
发布时间 :2004-04-19 00:00:00
修订时间 :2016-10-17 23:03:22
NMCOE    

[原文]SQL injection vulnerability in userlogin.php in Phorum 3.4.7 allows remote attackers to execute arbitrary SQL commands via doubly hex-encoded characters such as "%2527", which is translated to "'", as demonstrated using the phorum_uriauth parameter to list.php.


[CNNVD]Phorum Phorum_URIAuth远程SQL注入漏洞(CNNVD-200404-071)

        
        Phorum是一款基于WEB的论坛程序。
        Phorum没有充分过滤用户提交的输入,远程攻击者利用这个漏洞进行SQL注如入攻击,可获得敏感信息或破坏数据库。
        由于Phorum包含的脚本'include/userlogin.php'对'$user'参数缺少充分过滤,虽然程序使用了"Magic quotes",但$phorum_uriauth使用"%2527"参数,后续的urldecode()操作就会解析成"'",因此提交恶意SQL命令给参数,可绕过原有数据库逻辑,获得敏感信息或者可以更改数据库操作。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:phorum:phorum:3.4.8Phorum 3.4.8
cpe:/a:phorum:phorum:3.4.7Phorum 3.4.7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1938
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1938
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200404-071
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108239796512897&w=2
(UNKNOWN)  BUGTRAQ  20040419 [waraxe-2004-SA#019 - Critical sql injection bug in Phorum 3.4.7]
http://www.securityfocus.com/bid/10173
(VENDOR_ADVISORY)  BID  10173
http://www.waraxe.us/index.php?modname=sa&id=19
(VENDOR_ADVISORY)  MISC  http://www.waraxe.us/index.php?modname=sa&id=19
http://xforce.iss.net/xforce/xfdb/15894
(VENDOR_ADVISORY)  XF  phorum-userlogin-sql-injection(15894)

- 漏洞信息

Phorum Phorum_URIAuth远程SQL注入漏洞
高危 输入验证
2004-04-19 00:00:00 2005-10-20 00:00:00
远程  
        
        Phorum是一款基于WEB的论坛程序。
        Phorum没有充分过滤用户提交的输入,远程攻击者利用这个漏洞进行SQL注如入攻击,可获得敏感信息或破坏数据库。
        由于Phorum包含的脚本'include/userlogin.php'对'$user'参数缺少充分过滤,虽然程序使用了"Magic quotes",但$phorum_uriauth使用"%2527"参数,后续的urldecode()操作就会解析成"'",因此提交恶意SQL命令给参数,可绕过原有数据库逻辑,获得敏感信息或者可以更改数据库操作。
        

- 公告与补丁

        厂商补丁:
        Phorum
        ------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Phorum Upgrade phorum-3.4.8a.tar.gz
        
        http://phorum.org/downloads/phorum-3.4.8a.tar.gz

- 漏洞信息 (24016)

Phorum 3.4.x Phorum_URIAuth SQL Injection Vulnerability (EDBID:24016)
php webapps
2004-04-19 Verified
0 Janek Vind
N/A [点击下载]
source: http://www.securityfocus.com/bid/10173/info

Reportedly Phorum is affected by a remote SQL injection vulnerability. This issue is due to a failure of the application to properly sanitized user supplied URI input.

This issue may allow a remote attacker to manipulate query logic, leading to unauthorized access to sensitive information such as the user password hash or corruption of database data. SQL injection attacks may also potentially be used to exploit latent vulnerabilities in the underlying database implementation.

http://www.example.com/index.php?modname=saf&id=4		

- 漏洞信息

16904
Phorum userlogin.php phorum_uriauth Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Phorum contains a flaw that may allow an attacker to inject arbitrary SQL queries. The issue is due to the "phorum_uriauth" variable in the "userlogin.php" script not being properly sanitized and may allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-04-20 Unknow
2004-04-18 Unknow

- 解决方案

Upgrade to version 3.4.8a or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站