CVE-2004-1930
CVSS4.3
发布时间 :2004-04-12 00:00:00
修订时间 :2016-10-17 23:03:13
NMCOE    

[原文]Cross-site scripting (XSS) vulnerability in the cookiedecode function in mainfile.php for PHP-Nuke 6.x through 7.2, when themes are used, allows remote attackers to inject arbitrary web script or HTML via a base64-encoded user parameter or cookie.


[CNNVD]PHP-Nuke CookieDecode远程跨站脚本漏洞(CNNVD-200404-016)

        
        PHP-Nuke是一个广为流行的网站创建和管理工具,它可以使用很多数据库软件作为后端,比如MySQL、PostgreSQL、mSQL、Interbase、Sybase等。
        PHP-Nuke包含的mainfile.php脚本cookiedecode()函数对用户提交输入缺少充分过滤,远程攻击者可以利用这个漏洞进行跨站脚本攻击,可获得用户敏感信息。
        'cookiedecode()'函数不正确过滤用户提供的cookie参数,攻击者构建恶意连接,诱使用户访问,可导致恶意代码在用户浏览器上执行,使攻击者获得目标用户敏感信息。
        

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:francisco_burzi:php-nuke:7.2
cpe:/a:francisco_burzi:php-nuke:6.0
cpe:/a:francisco_burzi:php-nuke:7.0
cpe:/a:francisco_burzi:php-nuke:6.6
cpe:/a:francisco_burzi:php-nuke:6.5_rc1
cpe:/a:francisco_burzi:php-nuke:7.1
cpe:/a:francisco_burzi:php-nuke:7.0_final
cpe:/a:francisco_burzi:php-nuke:6.5_rc2
cpe:/a:francisco_burzi:php-nuke:6.9
cpe:/a:francisco_burzi:php-nuke:6.5_beta1
cpe:/a:francisco_burzi:php-nuke:6.5_rc3
cpe:/a:francisco_burzi:php-nuke:6.7
cpe:/a:francisco_burzi:php-nuke:6.5
cpe:/a:francisco_burzi:php-nuke:6.5_final

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1930
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1930
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200404-016
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108182759214035&w=2
(UNKNOWN)  BUGTRAQ  20040412 [waraxe-2004-SA#016 - Cross-Site Scripting aka XSS in phpnuke 6.x-7.2 part 3]
http://www.securityfocus.com/bid/10128
(VENDOR_ADVISORY)  BID  10128
http://www.waraxe.us/index.php?modname=sa&id=16
(VENDOR_ADVISORY)  MISC  http://www.waraxe.us/index.php?modname=sa&id=16
http://xforce.iss.net/xforce/xfdb/15842
(VENDOR_ADVISORY)  XF  phpnuke-cookiedecode-xss(15842)

- 漏洞信息

PHP-Nuke CookieDecode远程跨站脚本漏洞
中危 输入验证
2004-04-12 00:00:00 2005-10-20 00:00:00
远程  
        
        PHP-Nuke是一个广为流行的网站创建和管理工具,它可以使用很多数据库软件作为后端,比如MySQL、PostgreSQL、mSQL、Interbase、Sybase等。
        PHP-Nuke包含的mainfile.php脚本cookiedecode()函数对用户提交输入缺少充分过滤,远程攻击者可以利用这个漏洞进行跨站脚本攻击,可获得用户敏感信息。
        'cookiedecode()'函数不正确过滤用户提供的cookie参数,攻击者构建恶意连接,诱使用户访问,可导致恶意代码在用户浏览器上执行,使攻击者获得目标用户敏感信息。
        

- 公告与补丁

        厂商补丁:
        Francisco Burzi
        ---------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.phpnuke.org

- 漏洞信息 (23990)

PHP-Nuke 6.x/7.x CookieDecode Cross-Site Scripting Vulnerability (EDBID:23990)
php webapps
2004-04-13 Verified
0 waraxe
N/A [点击下载]
source: http://www.securityfocus.com/bid/10128/info

Reportedly PHP-NuKe is prone to a remote cross-site scripting vulnerability. This issue is due to a failure of the 'cookiedecode()' function to properly sanitize user supplied cookie parameters.

These issues could permit a remote attacker to create a malicious link to the vulnerable application that includes hostile HTML and script code. If this link were followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

http://localhost/nuke71/index.php?user=MTo8c2NyaXB0PmFsZXJ0KGRvY3VtZW50LmNvb2tpZSk7PC9zY3JpcHQ%2bZm9vYmFy		

- 漏洞信息

59297
PHP-Nuke mainfile.php cookiedecode Function XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-04-12 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站