CVE-2004-1912
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 23:02:49
NMCOE    

[原文]The (1) modules.php, (2) block-Calendar.php, (3) block-Calendar1.php, (4) block-Calendar_center.php scripts in NukeCalendar 1.1.a, as used in PHP-Nuke, allow remote attackers to obtain sensitive information via a URL with an invalid argument, which reveals the full path in an error message.


[CNNVD]NukeCalendar多个漏洞(CNNVD-200412-640)

        用于PHP-Nuke的NukeCalendar 1.1.a版本中的(1)modules.php、(2)block-Calendar.php、(3)block-Calendar1.php、(4)block-Calendar_center.php脚本存在漏洞。远程攻击者可以借助带有无效参数的URL获得敏感信息,该漏洞在出错消息中泄露了全部路径。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:shiba-design:nukecalendar:1.1.a
cpe:/a:francisco_burzi:php-nuke:8.0_final

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1912
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1912
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-640
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108144168932458&w=2
(UNKNOWN)  BUGTRAQ  20040408 [waraxe-2004-SA#015 - Multiple vulnerabilities in NukeCalendar v1.1.a]
http://www.securityfocus.com/bid/10082
(UNKNOWN)  BID  10082
http://xforce.iss.net/xforce/xfdb/15795
(UNKNOWN)  XF  nuke-calendar-path-disclosure(15795)

- 漏洞信息

NukeCalendar多个漏洞
中危 输入验证
2004-12-31 00:00:00 2006-09-22 00:00:00
远程  
        用于PHP-Nuke的NukeCalendar 1.1.a版本中的(1)modules.php、(2)block-Calendar.php、(3)block-Calendar1.php、(4)block-Calendar_center.php脚本存在漏洞。远程攻击者可以借助带有无效参数的URL获得敏感信息,该漏洞在出错消息中泄露了全部路径。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息 (23928)

NukeCalendar 1.1 .a modules.php Path Disclosure (EDBID:23928)
php webapps
2004-04-08 Verified
0 Janek Vind
N/A [点击下载]
source: http://www.securityfocus.com/bid/10082/info

NukeCalendar, which is a third-party calendar module for PHP-Nuke, is prone to multiple vulnerabilities.

These issues include path disclosure, SQL injection and cross-site scripting. Possible consequences include disclosure of sensitive information and account/bulletin board compromise. Attacks against the database implementation itself are also possible through SQL injection. 

http://www.example.com/nuke71/modules.php?op=modload&name=Kalender&file=index&type=view&eid=foobar		

- 漏洞信息 (23929)

NukeCalendar 1.1 .a block-Calendar.php Path Disclosure (EDBID:23929)
php webapps
2004-04-08 Verified
0 Janek Vind
N/A [点击下载]
source: http://www.securityfocus.com/bid/10082/info
 
NukeCalendar, which is a third-party calendar module for PHP-Nuke, is prone to multiple vulnerabilities.
 
These issues include path disclosure, SQL injection and cross-site scripting. Possible consequences include disclosure of sensitive information and account/bulletin board compromise. Attacks against the database implementation itself are also possible through SQL injection.

http://www.example.com/nuke71/blocks/block-Calendar.php		

- 漏洞信息 (23930)

NukeCalendar 1.1 .a block-Calendar1.php Path Disclosure (EDBID:23930)
php webapps
2004-04-08 Verified
0 Janek Vind
N/A [点击下载]
source: http://www.securityfocus.com/bid/10082/info
 
NukeCalendar, which is a third-party calendar module for PHP-Nuke, is prone to multiple vulnerabilities.
 
These issues include path disclosure, SQL injection and cross-site scripting. Possible consequences include disclosure of sensitive information and account/bulletin board compromise. Attacks against the database implementation itself are also possible through SQL injection.

http://www.example.com/nuke71/blocks/block-Calendar1.php		

- 漏洞信息 (23931)

NukeCalendar 1.1 .a block-Calendar_center.php Path Disclosure (EDBID:23931)
php webapps
2004-04-08 Verified
0 Janek Vind
N/A [点击下载]
source: http://www.securityfocus.com/bid/10082/info
  
NukeCalendar, which is a third-party calendar module for PHP-Nuke, is prone to multiple vulnerabilities.
  
These issues include path disclosure, SQL injection and cross-site scripting. Possible consequences include disclosure of sensitive information and account/bulletin board compromise. Attacks against the database implementation itself are also possible through SQL injection.

http://www.example.com/nuke71/blocks/block-Calendar_center.php		

- 漏洞信息

17989
PHP-Nuke NukeCalendar Module modules.php Path Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality Upgrade
Exploit Public Vendor Verified, Uncoordinated Disclosure

- 漏洞描述

The NukeCalendar module for PHP-Nuke contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when a remote attacker sends a specially-crafted URI request to the 'modules.php' script, which will disclose the software's installation path resulting in a loss of confidentiality. While such information is relatively low risk, it is often useful in carrying out additional, more focused attacks.

- 时间线

2004-04-08 Unknow
2004-04-07 2004-04-19

- 解决方案

Upgrade to version 1.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站